Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Mouse stuck on the upper-left side of screen

  • Greetings, I own a Raspberry Pi 3b updated to 6.0 Dragonblaze and I tried to use a wire logitech mouse and wireless keyboard+mouse pad to play Scumm, dos and Amiga emulators, as I used to do in 4.1, but I can not control the arrow on 6.0 since it is stuck on the upper left of the screen. Is there any solution to this?

  • Developer
    Global moderator

    @yuominae hi! I believe this has been fixed for the 6.1, but I‘m not sure.

    @lmerckx could you confirm, please?

  • Revisor

    The problem I solved in 6.1 is not really the same: ScummVM crashed when no controller plugged but only a mouse or keyboard.

    And I use a wireless keyboard/mouse pad too without any problem on 6.0 (for ScummVM, Amiga and Dos).

    @YuOminae Which hardware do you use for mouse and keyboard ?

  • I use a regular logitech wired usb mouse and keyboard. It did work fine on 4.1 as far as I remember. However, I have checked something new. The fact is that I also use a PS3 bluetooth controller with recalbox, but if I don't activate it and use only the mouse and keyboard, the arrow works fine on Dos and Amiga (but Scumm vm does not boot). If I activate the PS3 controller , the arrow is stuck on the left side of the screen on Dos amiga and scumm vm (which now boots with the ps3 controller "on"). It's very weird.

  • Revisor

    @YuOminae As far as I understand, the problem of ScummVM which doesn't boot if your controller is off should be solved with Recalbox 6.1.

    Why it doesn't work with your controller on, I have no idea. But the mouse should be emulated with the left joystick of your controller.

    I don't really know how the PS3 controller is supported ... can it be a side-effect of it ?

Want to support us ?