Atari 800, Atari 5200, AppleII, GW



  • D'abord félicitation à l'équipe Recalbox pour leur travail ;-)
    Merci aussi à l'ensemble de la communauté de ce Forum.
    Bonjour,
    Je sais que le sujet a déjà été traiter ici
    Le sujet a été fermé avec la réponse que c'est corrigé dans la version 6.0 Finale
    • ________________________________________

    garmadon
    Pour ma part quasiment tout fonctionne sur PC x64, sauf les systèmes "Apple II", "Atari 800" , "Atari 5200" et "Game & Watch" qui plantent au démarrage des jeux (idem en rc2). J'ai pourtant tout les bios OK en vert dans le recalbox manager, et des ROMS fonctionnelles qui marchaient avec la version 4.
    Dans le log "es_log.txt" j'ai un warning " ...launch terminated with nonzero exit code 64000!".
    Et dans le log "es_launch.txt" j'ai des erreurs:
    • "Failed to open /recalbox/share_init/system/.emulationstation/themes/recalbox/data/ubuntu_condensed.ttf"
    • "open /dev/snd/seq failed: No such file or directory
    double free or corruption (fasttop)"
    quelqu'un reproduit ces problèmes ou aurait une idée ? merci .

    Or le problème et toujours présent chez moi avec la version 6.0 finale
    Recalbox 6.0 version finale X64
    PC I5 disque 2 To interne



  • @tpp1964 , moi aussi j'ai toujours le même problème.
    As tu des problèmes avec les mêmes systèmes ? le même message d'erreur.?
    Merci.



  • @garmadon
    Oui, identique,
    Je vais essayer de préparer un nouveau PC + Raspberri 3B+ pour voir si le problème persiste,
    1-Installation système recalbox
    2-Placement des roms (Atari, Apple,GW) puis test
    3-Overlay de Screenscraper (excellent travail d'ailleurs).

    Merci,



  • Sur pi3b+ tous ces systèmes fonctionnent (avec les bios requis bien sûr)



  • Merci @Scavy pour la réactivité, j'ai hâte de tester cela ;-).



  • Oui je confirme que pour moi aussi tous ces systèmes fonctionnent bien sur rpi3b+.
    Mais malheureusement pas en version x64!
    Les systèmes posant problème chez moi sont: Apple II, Game&Watch, Atari 800, Atari 5200, Sharp x68000.

    Vu que tous ces systèmes fonctionnaient bien avec la version précédente de Recalbox (avec les mêmes bios, mêmes roms et sur la même machine NUC), cela me fait penser qu'il y a sans doute un bug quelque part dans la version x64 de recalbox ou des couches logicielles de plus bas niveau (libretro, etc...).
    Est-ce que d'autres personnes utilisant la version x64, peuvent nous dire si cela fonctionne (ou pas) chez eux ?
    Merci.!!



  • Oui, se serai bien d'avoir des retour d'autres utilisateurs Recalbox 6.0 Dragonblaze X64. N’hésitez pas de faire remonter l'info.
    Merci à tous



  • bonjour,
    je confirme que sur mon p3b+ ça fonctionne mais pas sur mon RB pc x64



  • Bonjour,

    j'emmène ma pierre a l'édifice je n'ai pas de jeux atari 800 et 5200 mais je peux confirmer que je n'arrive pas en lancer de jeux sur les systèmes "Apple II" et "Game & Watch" sur PC x64 .
    Ras pour les BIOS.
    Je vous mets les logs :

    [2019/05/05 12:53:35.688] (INFO ) : Attempting to launch game...
    [2019/05/05 12:53:35.688] (INFO ) : Shutting down SDL AUDIO
    [2019/05/05 12:53:36.095] (INFO ) : Available and configurated : PLAYSTATION(R)3 Controller
    [2019/05/05 12:53:36.095] (INFO ) : Saved PLAYSTATION(R)3 Controller for player 0
    [2019/05/05 12:53:36.095] (INFO ) : No config for player 1
    [2019/05/05 12:53:36.095] (INFO ) : No config for player 2
    [2019/05/05 12:53:36.095] (INFO ) : No config for player 3
    [2019/05/05 12:53:36.095] (INFO ) : No config for player 4
    [2019/05/05 12:53:36.095] (INFO ) : Configure emulators command : -p1index 0 -p1guid 050000004c0500006802000000800000 -p1name "PLAYSTATION(R)3 Controller" -p1nbaxes 6 -p1devicepath /dev/input/event12
    [2019/05/05 12:53:36.095] (INFO ) : Controllers config : -p1index 0 -p1guid 050000004c0500006802000000800000 -p1name "PLAYSTATION(R)3 Controller" -p1nbaxes 6 -p1devicepath /dev/input/event12
    [2019/05/05 12:53:36.125] (INFO ) : python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc -p1index 0 -p1guid 050000004c0500006802000000800000 -p1name "PLAYSTATION(R)3 Controller" -p1nbaxes 6 -p1devicepath /dev/input/event12 -system apple2 -rom /recalbox/share/roms/apple2/Donkey.dsk -emulator default -core default -ratio auto
    [2019/05/05 12:53:37.747] (WARN!) : ...launch terminated with nonzero exit code 256!
    [2019/05/05 12:53:37.747] (INFO ) : Creating surface...
    [2019/05/05 12:53:37.775] (INFO ) : Created window successfully.
    [2019/05/05 12:53:37.829] (INFO ) : Added known joystick PLAYSTATION(R)3 Controller (instance ID: 0, device index: 0)
    [2019/05/05 12:53:38.021] (ERROR) : VolumeControl::init() - Failed to find mixer elements!
    [2019/05/05 12:53:38.028] (INFO ) : SDL AUDIO Initialized
    [2019/05/05 12:53:38.028] (INFO ) : playing

    Merci.



  • @zigou45, merci.
    Cela semble être le même problème que moi, @tpp1964, et @lecureuil38.



  • Idem chez moi. Apple II, Game&Watch, Atari 800, Atari 5200 et Sharp x68000 ne fonctionnent plus sur mon PC x64 (carte vidéo Intel intégré, il semblerait que sur certains PC à base de nVidia les Atari fonctionnent ???) alors que les mêmes bios et roms (sur NAS) fonctionnent parfaitement sur pi 3 et fonctionnaient avant la version 6.



  • @kraran.
    oui moi aussi, il s'agit d'un NUC avec chipset Intel HD graphics.



  • @tpp1964
    Après test, c’est identique chez moi avec les jeux Game&Watch sur la Persson PC 😢


Log in to reply
 

Want to support us ?

Join us on :

247
Online

39967
Users

16886
Topics

127115
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.