Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Recalbox 6.0 is OUT! Codename: Dragonblaze

  • Banned

    This post is deleted!

  • As I can edit my previous message, I've got new issues:

    1. Wifi is not working when I "reboot" from Putty. Then I need to manually go into the menu, disable and enable the wifi to have a connected status and get my IP.

    2. My 2.4g keyboard is not detected by the RPi. I looked at lsusb and /dev/input/ as mentioned here https://github.com/recalbox/recalbox-os/wiki/Keyboard-encoder-configuration-(EN)
      My keyboard (no name purchased on https://www.aliexpress.com/item/Desxz-Original-H9-2-4G-Mini-Wireless-Game-Keyboard-RGB-Backlit-With-7-Colorful-Backlight-Touchpad/32923551234.html) is not listed here: https://github.com/recalbox/recalbox-os/wiki/Compatibility-(EN) but works with Raspbian/Windows/Android TV...
      Any help?

    3. Scrapper doesn't work, it goes back to black screen with pacman ghosts and recalbox logo

  • Hello guys, thank you for this release and for all the good work! I have some problems with N64 though that I never experienced on the older versions. From the gamelist menu, when I run any N64 game, I get the screen "recalbox'" and then it comes back to the menu. It's the same for all the N64 games whatever the file extension. I didn't modify anything, just installed the latest version, put a ps4 controller and added some games... Do you know what is going on? Thanx a lot

  • Hi, this new release looks awesome but I am having an issue with the x64 build. I have tried on 2 separate machines and 2 separate hard drives. It all starts well, I get my roms copied over and games play. Then randomly it reboots and I've lost everything. It seems like the main partition is being lost. All the config and log files show 0bytes size. I've tried everything I can to resolve this but I'm not a Linux guy or a developer so I'm kinda lost now. Any help would be very much appreciated.

  • I managed to get this from a log.

    May 1 13:17:17 RECALBOX user.err kernel: [ 11.849940] EXT4-fs (sda3): error loading journal
    May 1 13:17:17 RECALBOX user.info usbmount[554]: /dev/sda does not contain a filesystem or disklabel
    May 1 13:17:17 RECALBOX user.info usbmount[570]: executing command: mount -text4 -onoexec,nodev,noatime,nodiratime /dev/sda3 /media/usb0
    May 1 13:17:17 RECALBOX user.err kernel: [ 11.980833] EXT4-fs (sda3): couldn't mount as ext3 due to feature incompatibilities
    May 1 13:17:17 RECALBOX user.err kernel: [ 11.981109] EXT4-fs (sda3): couldn't mount as ext2 due to feature incompatibilities
    May 1 13:17:19 RECALBOX user.err kernel: [ 14.385032] JBD2: Invalid checksum recovering block 22 in log
    May 1 13:17:20 RECALBOX user.warn kernel: [ 15.521924] JBD2: recovery failed
    May 1 13:17:20 RECALBOX user.err kernel: [ 15.521928] EXT4-fs (sda3): error loading journal

  • Developer
    Global moderator

    @recalmanc try flashing your sd card again and wait patiently when booting up recalbox the first time until you reach ES. Otherwise partitions won’t be created properly.

  • @paradadf Thanks for the reply - I have done this several times. It completes and the larger drive is there; I get it loaded up with ROMS and then randomly it looses that partition and goes back to basic settings.

    I'm running this on a 240gb SSD, i7 with 4GB RAM.

  • Developer
    Global moderator

    @recalmanc can you give me the output of df -h?

  • @paradadf

    df -h

    Filesystem Size Used Available Use% Mounted on
    none 1.9G 0 1.9G 0% /dev
    /dev/sda2 1.9G 1.6G 206.6M 89% /
    tmpfs 1.9G 0 1.9G 0% /dev/shm
    tmpfs 1.9G 12.0K 1.9G 0% /tmp
    tmpfs 1.9G 5.1M 1.9G 0% /var
    tmpfs 1.9G 300.0K 1.9G 0% /run
    /dev/sda1 63.0M 10.0M 53.0M 16% /boot
    /dev/sda3 217.0G 39.5G 166.5G 19% /recalbox/share
    /dev/sda3 217.0G 39.5G 166.5G 19% /media/usb0

  • Developer
    Global moderator

    @recalmanc it looks good to me. Sadly, I don’t know what’s happening.

  • @recalmanc , this also happened to me several times.
    I think, it may happened because you don't shutdown recalbox properly.
    Do not shutdown using the PC power ON/Off button, but use software "Shutdown" in the recalbox menu instead. If you not shutdown properly, the "share" partition will not be unmounted properly, and recalbox will not be able to mount it again at the next boot because the partition will have errors.
    If it happened, unplug your hard disk and plug it under a linux system, then use "fsck" command to repair the faulty partition, it worked for me.

  • @garmadon That makes sense as I just noticed that the "Skraper" app I was using was restarting my recalbox machine after each system was complete. I guess it doesn't shut it down correctly. I have stopped using it and I've been stable for a lot longer than I have so far.

    Thank you for your help.

  • @paradadf No worries, I think I worked it out (see below). Thanks for trying to assist though! 🙂

  • @recalmanc , yes i think you're right. Skraper may be responsible.
    It happened to me just yesterday at the end of a scrap using the same software.
    Skraper reboot the whole operating system after each scrap. It should restart only "emulation station".

  • @garmadon 🙂 At least I wasn't going insane 🙂 Now all I have to do is work out how to make this all work with my x-Arcade Dual joystick and put it all in my cabinet and I'm good to go!

    Thanks for everyones help.

  • My Wifi isn't working until I re enter the password everytime even without any special characters. Is there a solution for this?

  • Hello, first of all Recalbox is one of the finest thing out there.Thx for all the good work.
    Is there some new informations about x86 x64_84 installation/startup issues. I used to have 18.7.13 which was great.
    But I never got any update for dragonblaze, which from what I found out on this forum doesn t work. You need to install a fresh copy.
    So I made a backup, at least stuff is secured. Used Balenea to install the dragonbalze on my Ssd. Installation stars at least screens shows booting recalbox. After a while the ES interface appears shows which music is playing then goes back to the black screen with booting recalbox. I waited at least 30 min but nothing happend.I am able to acces web interface from the recalbox, from there I restart ES the interface shows up a then dissapears after 5 sec again. This is the issue with x86. On the 64 version interface seems to work a bit better but when I try to pair a bluetooth controller, it also crahes the interface and I m again on the booting recalbox screen. From the webinterface I can also restart Es interface but pairing seems not to work well.
    I decided to install the beta version from santa claus and febuary from the forum. The issues is exactly the same.
    Cloud it be that the 6 builds version have some hardware compatibility issues?

    My config is the following.
    Intel Core 2 Duo E8400
    Intel Gma4500
    Ssd 500G Adata Spx900.

    Is there a way to download the 18.7.13 x86 again ?

    Best regards.

  • Quick question, in the changelog it lists gamecube mayflash support, does that mean support for it in "PC" mode or "Wii U" mode?

    I only ask because dolphin supports rumble in "Wii U" mode, but not PC mode, and all the other emulation OS's I've tried only support PC mode.

  • The last release of recallbox works extremely poorly, where you can download old versions for 2018 ?????

  • Developer
    Global moderator

    @fedor great first message! And as your information is, from the users experiences, not true, I recommend you to do some research before posting again.

Want to support us ?