Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Systèmes qui plantent sur PC x64



  • @acris, merci du conseil.
    J'ai enlevé le dossier "\system\configs\retroarch\overlays".
    Je viens de tester après reboot mais c'est pareil.
    Je suis sur que les overlays ont bien été désinstallés, car tous les autres systèmes fonctionnent et sans les overlays à l'écran.


  • Staff
    Moderator
    Team

    @garmadon
    relance un jeu et refais une archive.
    tu as reconfiguré ta manette dans emulationstation si non, fais le et teste.
    evite atari800 le bug est confirmé me semble t il par bkg2k



  • Nouvelle archive, sans overlays et après tests de lancement "game & watch" et "x68000":
    https://file.ac/xTUyS6gt104/

    Ma manette est bien configurée.
    OK pour l'atari 800.
    Merci!!


  • Staff
    Moderator
    Team

    @garmadon
    jai testé game & watch et sharp X6800 sur rpi3b+ et j ai aucun soucis.
    sauvegarde puis supprime tes gamelist elles sont peut etre corrompu si tu as scrappé ton système
    Ton romset game & watch a quel âge ?

    dans ton archive sont listé encore tous les fichiers atari800..cfg dans /recalbox/configs/retroarch/
    supprime les.


  • Banned

    pour la game & watch il faut un set récent, il a changé il y a un an, un an et demi et celui d'avant ne marche plus



  • @voljega , j'ai téléchargé aujourd'hui le romset officiel indiqué dans le fichier "/share/roms/gw/readme.txt" depuis le site libretro, et tout rescrapé.
    Le système "'game & watch" marchait sur l'ancienne version stable (RPI3 et PC x64), et je confirme qu'il marche aussi sur la 6.0 RC3 pour RPI 3b+, mais il ne fonctionne pas sur ma version 6.0 RC3 pour PC x64. J'ai pas l'impression que le problème provienne des ROMS mais plus de l'émulateur.

    PS: il faudrait mettre à jour le lien de téléchargement du romset gw dans le readme.txt, le lien à changé, le nouveau lien est "http://bot.libretro.com/assets/cores/Handheld Electronic Game/"

    Est-ce que quelqu'un d'autre a testé sur PC x64 .?
    Merci pour votre aide.


  • Staff
    Moderator
    Team

    Jai demandé des retours sur le discord
    Pas eu de reponse pr le moment.
    Mais as tu tenté une installation propre avec uniquement les roms .?
    Et aussi tester en supprimant ton scrp avec gamelist



  • @acris , Ok je viens de ressayer, en procédant de la manière suivante:

    • Je reinstall proprement une 6.0 RC3 pour PC x64
    • je copie une ROM "game & watch" à jour dans "/share/roms/gw" (téléchargée ce jour depuis site libretro)
    • je lance le jeu, et ca plante 1-2 secondes après

    Dans un second temps, j'ai ajouté les bios (tous OK dans le manager), et quelques ROMS (à jour et qui fonctionnent toutes sur la 6.0 RC3 pour RPI3b+, et qui fonctionnaient toutes avec la dernière stable sur un RPI3 et sur le même PC x64)
    Puis j'ai refait le même test pour les autres systèmes "apple2", "atari 5200", et "x68000", et j'ai le même problème de plantage au lancement du jeu

    ci-dessous l'archive faite sur ce système propre:
    https://file.ac/OVPqPE2jNVE/

    Je viens d'essayer la même procédure, avec les mêmes systèmes, les mêmes bios et les mêmes ROMS sur un RPI 3B+, ils ont tous fonctionnés tout de suite.

    PS: Que penses tu des messages d'erreur dans mes logs que j'ai signalé plus haut ?.
    ("...launch terminated with nonzero exit code 64000!") . J'obtiens ce message à chaque fois que je lance un des 5 systèmes posant problème et qui plante au démarrage.
    J'ai des messages d'erreur également dans les logs "\system\logs\es_launch_stderr" et "\system\logs\es_launch_stdout".

    Merci bonne soirée, bon week-end.



  • @garmadon :
    idem pour moi sur GW en RC3 x64 :ko alors que ça fonctionne sur mon pi3b+.
    pas d'Atari 800.
    daphné fonctionne maintenant suite au rajout du répertoire ROMS.
    dreamcast toujours KO malgré les bon bios



  • @lecureuil38 , merci pour le retour.
    Peux-tu svp regarder tes fichiers logs, voir si tu as les mêmes messages d'erreur que moi ?
    (Recalbox manager -> logs -> es_log.txt)
    As- tu la possibilité de tester "sharp x68000", "atari 5200" et "apple 2" ?
    Pour "atari 800", @acris a confirmé un problème connu.

    J'ai retesté la dreamcast en x64 fonctionne chez moi.
    as tu bien les 2 fichiers bios dc_flash.bin et dc_boot.bin ?



  • @garmadon , pour dreamcast, j'ai les bons bios que j'ai eu du mal a trouvé.
    je vais tester le sharp , et l'apple 2 parque j'ai des roms.

    edit:
    je viens de tester et ni l'apple2 ni le sharp fonctionnent, c'est le retour au menu direct.



  • N oubliez pas de supprimer le rep recalbox si il est sur un HD et faire une remise a 0 .. c est ce que j ai fais car j avais un retours directe au menu sous Neogeo . (J ai meme eu le cas sous dolphin car j avais pas branché la manette ps4 pour tester une autre.. va savoir pourquoi une fois rebranché l emul c est lancé)

    Sinon sur la RC2 classique et la RC3 NVIDIA les roms Game & Watch et Atari 5200 tournent nikel avec une carte graphique Nvidia pour ma part tout fonctionne pour le moment . Sauf le core N64 par defaut (sur la RC3) qui lui ce trouve en bas gauche de l ecran 😯😯 et non centré pourtant l image est plus belle et sur le 2 eme core lui est centré mais trop de pixels



  • Sur PC x64, video intel intégré core i5, sur la 6.0 finale avec roms sur NAS : Atari 5200, Apple 2 et Game & Watch ne fonctionne pas. Dreamcast : les .gdi ne fonctionne pas. Tout fonctionnait (à part la 5200 bien sûr) sur la 18.07.13 et tout fonctionne parfaitement sur Retroarch 1.7.6 Windows sur le même PC avec les même roms…


  • Staff
    Moderator
    Netplay

    Bonjour @kraran

    • Atari 5200 fonctionne chez moi au poil !!! vérifie tes roms !!!
    • la Sharp X68000 fonctionne aussi chez moi sans problème pareil vérifie test roms
    • la apple2 ne ce lance pas problème avec l’émulateur qui est pas de chez libretto et a aussi était retravailler pour Recalbox un peu comme piffa si je ne pas de bêtise @bkg2k doit s'occuper de son cas
    • la Dreamcast : le core reicast a était bump si je ne m'abuse d’où le probable soucis avec les fichiers .gdi

    merci de lancer les émulateurs mis en cause et de faire une archive support depuis le webmanager onglet depannage puis executer le script
    merci


Log in to reply
 

Want to support us ?

180
Online

62230
Users

18661
Topics

140167
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.