[Installation] Corruption de partition Ext4 à l'installation



  • Bonjour à tous, tout d'abord, un grand bravo au(x) développeur(s) pour tout le travail accompli. Je me tourne vers ce forum pour signaler un étrange phénomène lors de mes tests d'installation de Recalbox, ie une corruption de partition. Contexte:

    • Raspberry PI 2 à peine sorti de son emballage
    • Carte mémoire µSD Lexar 633x UHC-i 16 GB, nommée PI, formattée avec SDFormatter et FormatGui en FAT32, 32K/cluster

    Observations et test: En premier lieu, pour situer le contexte, le phénomène ressemble à des problèmes déjà signalés ici mais n'ayant pas reçu de réponse claire, pointant toujours du doigt la carte mémoire mais mes divers tests ne m'en convainquent pas. Je m'explique. Pour information, j'ai déjà vérifié si cette carte figure dans la liste de compatibilité du site, elle n'en fait pas explicitement partie mais ressemble à ces cousines de la même marque, compatibles (je suis conscient qu'une liste exhaustive serait impossible). Mes tests d'installation:

    • Recalbox 3.3 beta 16 + N00bs 1.4.2: échec en fin d'installation à l'étape [Cleaning up EBR] avec un message indiquant un problème de majuscule dans les noms FAT
    • Recalbox 3.2.11+ N00bs 1.4.2: échec en fin d'installation à l'étape [Cleaning up EBR] avec un message indiquant un problème de majuscule dans les noms FAT
    • Recalbox 3.3 beta 16 + N00bs 1.5: ayant lu que ces problèmes de FAT étaient liés à des patches dans N00bs (MAJ du kernel Linux en v3.18.5 au lieu de 3.6.11), j'ai mis le contenu de Recalbox dans le dossier "Os" d'un N00bs v1.5 puis testé. Résultat: installation réussie mais ici, 2 fois sur 3, échec au lancement de Recalbox après le reboot en fin d'installation avec une belle erreur de corruption de la partition en ext4 puis un kernel panic. 1 fois sur 3, en fin d'installation, Recalbox se lance au reboot mais après le reboot suivant, réapparition du message de corruption de la partition.
    • Recalbox 3.2.11 + N00bs 1.5: même observation

    On pourrait penser à une incompatibilité de la carte mémoire sur le PI 2, or:

    • installation de Raspbian + N00bs 1.4.2 :  Succès
    • installation de Raspbian + N00bs 1.5 :  Succès
    • installation de OSMC+ N00bs 1.5 :  Succès

    Dès lors, avec ceci, il semblerait que le souci ne soit pas situé au niveau de N00bs mais de la méthode d'installation de Recalbox, apparemment différente de celle de Raspbian, et surtout de choses faites avant le reboot en fin d'installation (mauvais sync ?). On remarque bien que la MAJ du kernel a aidé à avancer dans le processus d'installation. Voici mes observations, si elles peuvent aider, bien sûr je pourrais céder à la facilité en achetant un autre modèle de carte mémoire mais avec tout cela, je me demande si la racine du problème n'est pas plus "locale" 🙂 Si quelqu'un est intéressé par des dumps, pas de souci. Des idées ?   Merci d'avance,



  • Bonjour Je ne sais pas du tout si sa vas réglé ton problème mais as tu essayé de mètre seulement recalbox sur t'as micro sd ?



  • Comme expliqué plus haut, tous mes tests ont été effectués avec seulement Recalbox sur la µSD pour écarter tout risque de conflit.


  • Staff
    Developer
    Global moderator
    Team

    Salut, oui les lexaar posent pas mal de problèmes. Le kernel passe en 4.X dans une prochaine mise à jour sur laquelle nous travaillons, ca changera peut etre la donne. Le noobs de recalbox est 99% identique au noobs de base, il faudra aussi que je merge les dernières modifications. En attendant, je te conseille de prendre une sandisk si tu veux vraiment utiliser recalbox 😞


  • Staff
    Developer
    Global moderator
    Team

    https://github.com/recalbox/recalbox-os/wiki/Compatibility-(EN) et si tu peux ajouter ta carte ici en tant que non cmpatible ça serait cool 😛



  • Je resterai à l’affût de vos mises à jour vers N00bs 1.5 et testerai. Je m'occuperai de mettre à jour la liste de compatibilité aussi. Bon courage !


Log in to reply
 

Want to support us ?

297
Online

80.4k
Users

21.6k
Topics

157.5k
Posts