Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

February 2019 Beta Version



  • @paradadf The file I found was
    recalbox\system\configs\retroarch\retroarchcustom.cfg
    and on line 108 for me snippet is:
    framecount_show = "false"
    and then its disabled.


  • Staff
    Team
    Moderator
    Translator

    @tobaunta thanks


  • Banned

    @bkg2k du coup c'est quand même dommage parce qu'avant 95% environ des jeux whdl marchaient... jamais trop eu confiance en leur truc perso, es t'on sur qu'il marche sans connection au moins ? parce que de mémoire je crois qu'il allait chercher les confs de lancement spécifique à chaque jeu dans une db ou un site web


  • Staff
    Moderator
    Team

    @simba51 @Amos I'm seeing the same issue (unstable WiFi 5G connection with SSH, SCP, HTTP or even ICMP). I have two solutions to this issue:

    • the workaround: connect to your not-5G network 😏 (it sounds silly, but it works: most routers offer both 2.4GHz and 5GHz)
    • the fix: I changed wifi.region in recalbox.conf from US to FR (I'm in France) and 5G WiFi started working perfectly ✨

    I hope it'll work for you as well as it did for me 🤗



  • Bonjour à tous , voici ce qui s'est passé pour moi avec cette nouvelle beta :

    setup : desktop pc (core i3 + gtx 670), hdd 2 TO (neuf), xbox 360 pc usb controller

    L'installation s'est bien passée, j'ai paramétré le système et clavier en français puis désactivé les mises à jour et ensuite j'ai balancé toutes mes roms.

    Quand j'ai voulu lancer un jeu dreamcast l'écran est resté figé sur la date et le gamepad ne répondait plus. J'ai du faire un reset à ma tour et au redémarrage je me suis retrouvé avec recalbox revenu au point de départ : message de logs de la beta, menu en anglais, plus aucune roms .... j'ai remis en français et ça ne tient pas. en gros le systeme se remet en config de départ à chaque redémarrage :/


  • Staff
    Moderator
    Team

    @reflectedsoul I think this is a known bug (mentioned in the first post of this thread), isn't it?

    Known bugs

    • Cannot go beyond the clock settings on Reicast (Dreamcast)


  • Hi, I'm testing the amiga 1200, I have added these bios:

    CRC32:
    kick33180.A500 A6CE1636
    kick34005.A500 C4F0F55F
    kick37175.A500 C3BDB240
    kick39106.A1200 6C9B07D2
    kick40063.A600 FC24AE0D
    kick40068.A1200 1483A091
    kick40068.A4000 D6BAE334

    MD5
    85ad74194e87c08904327de1a9443b7a *kick33180.A500
    82a21c1890cae844b3df741f2762d48d *kick34005.A500
    dc10d7bdd1b6f450773dfb558477c230 *kick37175.A500
    b7cc148386aa631136f510cd29e42fc3 *kick39106.A1200
    e40a5dfb3d017ba8779faba30cbd1c8e *kick40063.A600
    646773759326fbac3b2311fd8c8793ee *kick40068.A1200
    9bdedde6a4f33555b4a270c8ca53297d *kick40068.A4000

    but the emulator doesn't start

    tested with: [GAME].uae and [GAME].zip in the amiga1200 rom folder (the Christmas version worked fine)

    ES_log:
    Traceback (most recent call last):
    File "usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 249, in <module>
    exitcode = main(args)
    File "usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 174, in main
    command = generators[system.config['emulator']].generate(system, args.rom, playersControllers)
    File "/usr/lib/python2.7/site-packages/configgen/generators/amiberry/amiberryGenerator.py", line 228, in generate
    configFile.saveConfigFile()
    File "/usr/lib/python2.7/site-packages/configgen/generators/amiberry/amiberryConfig.py", line 23, in saveConfigFile
    self.settings.saveFile()
    File "/usr/lib/python2.7/site-packages/configgen/settings/keyValueSettings.py", line 45, in saveFile
    sf.write(key + "=" + self.settings[key] + '\n')
    TypeError: cannot concatenate 'str' and 'NoneType' objects

    System: Raspberry 3b+



  • This post is deleted!


  • Hi, Sorry, the bios file names are incorrect, the proper ones are:

    CRC32
    kick02019.AROS.rom 786D1739
    kick02019.AROS.ext.rom 805FB428
    kick33180.A500.rom A6CE1636
    kick34005.A500.rom C4F0F55F
    kick37175.A500.rom C3BDB240
    kick39106.A1200.rom 6C9B07D2
    kick40060.CD32.rom 1E62D4A5
    kick40060.CD32.ext.rom 87746BE2
    kick40063.A600.rom FC24AE0D
    kick40068.A1200.rom 1483A091
    kick40068.A4000.rom D6BAE334

    I have fixed the bios file names and the emulator works fine again ;-)


  • Tester

    @Bkg2k
    XU4 BT issue with 8bitdo SF30Pro controller

    Fresh install Beta Feb2019
    Board XU4
    Micro SD card only
    No Wifi
    No Theme
    RJ-45 network
    ASUS BT Dongle
    8bitdo SF30 Pro
    Bluez 5 driver

    I was able to pair the pad with ES
    I repad all controls in ES. Works fine. Restart XU4.
    Start 8bito do with "start + B" ie Dinput
    Controller is paied. Good :)

    Starting SNES game : Arkanoid but faild to push "start" ou "B" bouton.
    It is like if inside game remapping of boutons was done.
    I tried with wired pad and works ....

    Do not understand why BT 8bitdo pad SN30Pro has different way of working.
    it seems that there is a way to works in ES
    and a different one inside game :(


  • Staff
    Moderator
    Team

    @voljega Oui et non. Beaucoup de jeux se lancent, et parmis les lha qu'on trouve classiquement, rare sont ceux qui ne fonctionnent pas.
    La DB, il y en as une, mais elle est locale. L'avantage est qu'elle contient des tweaks et des trainers pour ceux qui aiment finir les jeux à la chaine :)


  • Staff
    Moderator
    Team

    @asirome Thanks for the detailed report. When no bios is availble, the configgen should fallback to AROS bios.
    This has to be fixed.


  • Banned

    @bkg2k ok donc en fait c'est une simple histoire de naming / MD5 pour que les jeux se lancent bien ?


  • Staff
    Moderator
    Team

    @voljega Pour les LHA oui.
    Pour ceux qui ont des WHDL en dossiers ou en zip, la structure des répertoires peut poser problème.



  • @Michael-Baudino

    EN
    Ok, thanx it works! At least for the connection...
    Cause the RPi 5G wifi is on "n" not "ac", I can see that in the card properties of my box (Freebox v6) while all my others devices are in "ac" on the same connection.
    So, the RPi have a low-speed acces :/

    FR
    Merci, ça marche! Du moins pour la connexion.
    Car le wifi du RPi en 5G est en "n" et non en "ac", je peux le voir dans les propriétés de la carte de ma box (Freebox v6), là où mes autres périphériques sont tous connectés en "ac" sur la même connexion.
    Du coup, le débit est lent sur le RPi :/



  • si je garde le nom des archive telecharger j aurais donc une meilleur chance que ca fonctionne pour les whdl



  • Autre message pour autre problème : chez moi les jeux PSP ne se lancent pas (petits, gros, ISO ou CSO peu importe), retour direct à la liste de jeux malgré la nouvelle version de la bêta avec les libs adéquates.
    Suis-je le seul ? Y a t-il un truc qui m'aurait échappé ?



  • Bonjour, je voudrais savoir si dans cette version ou une ultérieure dans le web manager on pouvait classer les bios comme dans le fichier lisez-moi.txt (par machine) et si on peux avoir un .dat de clrmamepro pour trier ses bios et avoir le bon nom.
    Merci.


  • Staff
    Moderator
    Netplay

    @amos le soucis a déjà était remonter il manque une librairie a l’émulateur !



  • @strodown
    Je croyais que le problème avait été résolu pourtant : "PPSSPP requires a missing library (libsnappy.so, beta image will be updated soon) (images x86/x64/c2/xu4 & Pi3 updated with the missing library)" dans Known bugs.


Log in to reply
 

Want to support us ?

183
Online

68020
Users

18956
Topics

141635
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.