Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

February 2019 Beta Version


  • Banned

    @zafeira there is a wiki full of informations inlcuding a complete manual and official tutos on youtube, all of your questions have their answers there.


  • Staff
    Moderator
    Team

    @zafeira said in February 2019 Beta Version:

    hi guys, just a newbie question on recalbox. When i will flash this image through etche then what shall i do? I am asking it has just emulators? can i try some rom for recalbox release? is it safe or can anyone suggest me any that's for sure playing on this beta version? Thanks in advance
    my sd card is samsung evo 32gb

    Please topic for bug report not support.



  • Hi all,
    Thank you for Recalbox. These are a couple of issues I have found on a RPi 3B+ with 64GB SD and 8bitdo controllers.

    • Hiding the last game in a system crashes ES (black screen, required reboot). Reproducible each time. I have 2 games in the Intellivision system, in the menu I went to edit the game's metadata and hid it, saved and exited the menu. There is just one game showing now. I did the same thing with the remaining game and got a black screen that I could not get out of. Here is the recalbox-support taken before rebooting: https://file.ac/awIRHvXyDeQ/

    • With the API enabled I tried this curl -X POST http://recalbox:1337/shutdowns but got "connection refused".

    • In the Recalbox Manager, making a change in the Configuration tab and trying to save fails with the message "An error occurred while saving the configuration."

    • Daphne games that were working on the Christmas beta now return to ES after a few seconds. I don't have more info so if you have some advice on debugging this I look into it.

    • Saving the state in the Amiberry menu exits the emulator and returns to ES. The state is not saved. I've tried only WHDL games in lha format but it happened on all of them.

    That's it for now, I hope it helps.



  • Beta image has no correct page alignment. When flashing the last image recalbox.2019-02-23-beta.rpi3.img.xz to an 256 GB micro SD card, I'll get the following partitions:

    Disk /dev/mmcblk0: 238.5 GiB, 256087425024 bytes, 500170752 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x4b10cc2b

    Device Boot Start End Sectors Size Id Type
    /dev/mmcblk0p1 1 131072 131072 64M c W95 FAT32 (LBA)
    /dev/mmcblk0p2 131073 4325376 4194304 2G 83 Linux
    /dev/mmcblk0p3 4325377 500170751 495845375 236.4G 83 Linux

    It should look like this:

    /dev/mmcblk0p1 1 131071 131071 63M c W95 FAT32 (LBA)
    /dev/mmcblk0p2 131072 4325375 4194304 2G 83 Linux
    /dev/mmcblk0p3 4325376 500170751 495845376 236,4G 83 Linux

    so that micro-SD card formatting for performance and wear-leveling is more optimal.



  • bon en faisant un fichier .uae ça fonctionne nickel et j ai même pu voir avec le fichier sur le wiki qu on peut modifier pas mal de chose ce qui est plutôt génial , je vais devoir regarder ça de plus près et peut être que je parviendrais a faire fonctionner les zool en version cd32 ^^



  • I would like to always run the amiberry with a config-file.
    FILE NAME? DIRECTORY? CONTENT? I DO NOT REALLY KNOW!

    ?? amiga600.uae ??

    ;gfx
    gfx_width=768
    gfx_height=216
    gfx_correct_aspect=true
    gfx_center_horizontal=simple
    gfx_center_vertical=simple

    ;misc
    show_leds=true

    my 4:3 tube tv recalbox: https://youtu.be/Sf7vDBAUCpY


  • Banned

    @virtualhours did you even bother rzading the wiki ?



  • @voljega The path in the wiki is wrong for amiberry config by system.


  • Banned

    @choum what do you mean ? still good on a per-game basis

    also maybe doc hasn't been updated after last beta work and for config by system



  • The pad does not work from xbox one s. It does not work over bluetooth and through the usb module (provided by xbox).

    After updating from the system level, the system does not work at all, the system has been updated, rebooted and the nil did not display outside the "load" icon.

    Translated by google translate.



  • @tarzinio I will add that I have RASPBERRY Pi 3 b +


  • Staff
    Moderator
    Team

    Hello

    • RPI3 b+
    • MicroSD 16 GO Scandisk class 10
    • idroid:con snakebyte gamepad
    	<inputConfig type="joystick" deviceName="idroid:con" deviceGUID="050000006964726f69643a636f6e0000" deviceNbAxes="4" deviceNbHats="1" deviceNbButtons="12">
    		<input name="a" type="button" id="2" value="1" code="290" />
    		<input name="b" type="button" id="1" value="1" code="289" />
    		<input name="down" type="hat" id="0" value="4" code="16" />
    		<input name="hotkey" type="button" id="10" value="1" code="298" />
    		<input name="joystick1left" type="axis" id="0" value="-1" code="0" />
    		<input name="joystick1up" type="axis" id="1" value="-1" code="1" />
    		<input name="joystick2left" type="axis" id="2" value="-1" code="2" />
    		<input name="joystick2up" type="axis" id="3" value="-1" code="5" />
    		<input name="l2" type="button" id="6" value="1" code="294" />
    		<input name="l3" type="button" id="10" value="1" code="298" />
    		<input name="left" type="hat" id="0" value="8" code="16" />
    		<input name="pagedown" type="button" id="5" value="1" code="293" />
    		<input name="pageup" type="button" id="4" value="1" code="292" />
    		<input name="r2" type="button" id="7" value="1" code="295" />
    		<input name="r3" type="button" id="11" value="1" code="299" />
    		<input name="right" type="hat" id="0" value="2" code="16" />
    		<input name="select" type="button" id="8" value="1" code="296" />
    		<input name="start" type="button" id="9" value="1" code="297" />
    		<input name="up" type="hat" id="0" value="1" code="16" />
    		<input name="x" type="button" id="3" value="1" code="291" />
    		<input name="y" type="button" id="0" value="1" code="288" />
    	</inputConfig>
    

    Bug Report :

    J'utilise le gamepad virtuel pour configurer la recalbox , et il demande d'être configuré ce qui ne devrait pas arrivé.
    Je pense que la configuration dans le es_input.cfg est manquante.



  • bonjour
    hier comme j avais un petit peut de temps de libre , j ai voulus jouer a la snes pour me defouler un peu lol
    quand j ai voulus lancer un jeux j ai eu un ecran noir et retour au menu donc j ai ete dans la configuration de l emulateur et j avais la configuration par defaut , la j ai mis le core liberto et l emulateur snesx comme c etait par defaut et j ai lancer le jeux et la ca a fonctionner , j ai lancer super mario yoshy island et j ai voulu charger une save (je n etais pas sur d en avoir une) il a charger et a 83% il a bloquer et plus moyen de rien faire donc je me demande si c est un bug ou pas ???



  • Just a small thing, the Security page in the Recalbox Manager is not localised. It is always in French regardless of the language actually selected.



  • @voljega Of course I have read it
    but I do not know where to go with the FILE "amiga600.uae"
    ON the boot sd or on the usb stick with all roms
    and which folder is really the right one



  • @choum said in February 2019 Beta Version:

    @voljega The path in the wiki is wrong for amiberry config by system.

    can you tell me which one is right for amiga600.uae


  • Banned

    @virtualhours said in February 2019 Beta Version:

    @voljega Of course I have read it
    but I do not know where to go with the FILE "amiga600.uae"
    ON the boot sd or on the usb stick with all roms
    and which folder is really the right one

    I'm pretty sure it was mentioned by @Bkg2k in this thread... otherwise he can help you


  • Tester

    @virus-man les save ne sont pas forcement compatible entre les emulateurs d'une meme systeme



  • When entering the Retroarch menu, there is a "Welcome to Retroarch" message shown for a few seconds. No input is taken during that time. I usually end up selecting the wrong option because of this.

    This is a minor annoyance but it can be solved easily. Would you consider adding this line to /recalbox/share/system/configs/retroarch/retroarchcustom.cfg :
    rgui_show_start_screen = false


  • Staff
    Moderator
    Team


Log in to reply
 

Want to support us ?

170
Online

61583
Users

18633
Topics

140016
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.