February 2019 Beta Version

  • Moderator

    Picture NES Familly

    New February 2019 Beta version! For Pi3B+ and ALL platforms!


    From the latest stable, this is the 3rd beta version. And the last until the next stable release!

    We know you're all impatients, and the team has been working hard to provide you with this almost-final beta version.
    The changelog is pretty long, and from now on, the repository includes a more user-friendly list of changes, available here: Beta RELEASE-NOTES.md
    or here, if you want to follow work-in-progress developments : WIP RELEASE-NOTES.md

    Thanks to all people that made bug reports in the previous beta thread. Almost everything has been fixed since the last beta.

    Beware: some emulators have been updated and requires new bios (i.e: Amiga - Read Here)


    Here we go! As usual, download the image and use Etcher to flash it on your favorite SD Card.




    Testing & Reporting

    What to test?

    ALL! Almost everything has been updated: Linux kernels, drivers, tools, all emulators and libretro cores, Retroarch, EmulationStation, ...

    What to report, and where?

    Any bug, bad behavior or suspect behavior should be reported here, or on our Discord server when it requires further discussion.
    When posting a bug report, please be as much accurate as you can.
    If possible, tell us:

    • The hardware your recalbox is running on
    • Anything specific in your configuration (exotic pad? HDD? USB? Network, ...)
    • Default or user/custom theme?
    • Optionnaly, if you have a big game collection, how many systems/games.

    When a particular emulator is not working:

    • Rom/game extentions
    • BIOS
    • Pad(s)

    The last beta has been released on many systems, and every single system has its own particularities!
    Without details, we won't be able to help you!

    Known bugs

    Here is the list of confirmed bugs.

    • Sound volume in EmulationStation may be louder than in-game depending of the platform you run Recalbox on.
    • Cannot go beyond the clock settings on Reicast (Dreamcast)
    • Configgen is crashing when no bios is available instead of selecting AROS bios
    • Cheats are not working with mame2010 (path issues)
    • PPSSPP requires a missing library (libsnappy.so, beta image will be updated soon) (images x86/x64/c2/xu4 & Pi3 updated)
    • Default mapping inverts A/B and X/Y buttons for XBox 360 pads (you can remap yourself)
    • Atati ST Screen is not centered and may be truncated
    • Frame counter is on by default in libretro cores
    • Configgen do not set graphics settings in Amiberry config file
    • EmulationStation loading is slower than before
    • Screen-ratio desync' between configgen/emulationstation and retroarch
    • Last played date shows a funny number when not defined (elapsed days from epoch time actually)
    • Broken gamelist.xml : Last played field not saved in compact ISO8601 format

    This list will be updated as soon as a new bug is discovered and confirmed or a bug is fixed.


    There is a popup telling me there is an update! Wow you're fast!
    NO! NO! NO! No update at all until the final release! update = crash

    My game doesn't launch :( I get a black screen and then it goes back to the gamelist...
    Remap your pad/joystick/whatever! Even if it's working in EmulationStation menus, your pad may not be in the known-pad-list. If it's still not working, check the required bios and/or the game you try to run.
    When your game is working after remapping, please read the post here!

    My game is buggy or there are glitches/artifacts...
    We are not making emulators :) Please report the issue to the appropriate emulator/core mainteners.

    Where can I find games or bios?
    Not here. Nor on our discord. Thanks.

    Testing & Reporting (for french people ;) )

    Lorsque vous rapportez un ou des bug(s), soyez le plus précis possible!
    Essayez d'indiquer:

    • Le hardware sur lequel tourne votre recalbox
    • Tout ce qui est spécifique à votre configuration (HDD, Reseau, USB, pad exotiques, ...)
    • Thème par défaut ou thème custom/utilisateur?
    • Optionnellement, si vous avez une grosse collection, le nombre de systèmes et de jeux.

    Si un émulateur en particulier ne fonctionne pas:

    • L'extension du jeu ou de la rom
    • Le(s) BIOS utilisé(s)
    • Le(s) Pad(s) utilisé(s)

    Merci de poster vos archives de support en utilisant le manager https://recalbox/help

    La dernière bêta est sortie sur tous les systèmes, et chaque système a ses propres particularités!
    Sans indications, il nous est peu ou pas possible de vous aider.

  • Thanks a lot !

  • Yesssssss!!!!! Appuyer sur F5 pendant des semaines dans l'attente de l'annonce de la nouvelle beta, ça commençait à faire mal aux doigts :)
    Plus sérieusement, merci mille fois, vous faites un boulot ÉNORME!!!!!!

  • Thanks a lot for this Feb release !!!
    Will try soon!!

  • Bonjour,

    Si j'utilise Etcher, vais-je perdre les roms installées avec la beta précédente ?



  • @marcus_972 Oui, parce que Etcher va écraser ta µSD avec l'image de la nouvelle version. Fais un backup de tes dossier avant.

  • Are there any known bugs we should be ignoring?

  • Moderator

    Known bugs section added in the first post. Will be updated everytime a bug is confirmed.

  • Mici mici mici mici pour votre énorme travail :)
    Keep it up ! :o)

  • Gros gros boulot... Félicitation à toute l'équipe Recalbox.

    1 problème identifié avec PSP sur PI3+ sur la version Février 2019, retour automatique à l'écran de lancement pour tous mes iso. Le fichier /recalbox/share/system/logs/es_launch_stderr.log indique l'erreur suivante : /usr/bin/PPSSPPSDL: error while loading shared libraries: libsnappy.so.1: cannot open shared object file: No such file or directory. Une idée pour la correction !? J'ai cherché, rien trouvé avec cette commande find / -name "libsnappy.so*"

  • Can we update from the Christmas beta or should we perform a clean installation?

  • Merci, je vais tester ça sur mon 3B+ :)

  • @pmroyo don't update, reinstall properly using etcher

  • @marcus_972 To avoid losing all your games next time, you can configure Recalbox to use an external drive (usually a USB drive) to store them (and your configuration). Next system update will only update the OS (you may have to configure it again after update to use the external USB drive, though). See @Fab2Ris tutorial #5 on Youtube: https://www.youtube.com/watch?v=65deA8c-stM

  • Moderator

    Known bug list updated.
    Concerning PPSSPP, since the missing library is a critical bug, beta images will be updated in a few days.

  • @nordicpower Tu avais le même soucis de pb de Psp sur la version précédente de recalbox ?

  • Many thanks for this build, it installs on my ASUS VivoMini VC65-C1 (i5-8400T, Intel HD Graphics 630) whereas the previous beta did not.

    It seems that recalbox-configgen is not configuring my F710 joypad in dreamcast/reicast (works fine so far in other emulators bundled in the build) I have tried re mapping the controller with no change.

    my controllerP1.cfg

    btn_trigger_left = 0
    axis_dpad1_y = 1
    btn_trigger_right = 0
    axis_dpad1_x = 0
    mapping_name = Logitech Gamepad F710
    btn_escape = 0
    btn_b = 0
    btn_a = 0
    btn_x = 0
    btn_start = 0
    btn_y = 0
    axis_y = 0
    axis_x = 0

    my emu.cfg

    backend = auto
    disable = 0
    Debug.SerialConsoleEnabled = 0
    Dreamcast.Broadcast = 4
    Dreamcast.Cable = 3
    Dreamcast.RTC = -2113930091
    Dreamcast.Region = 3
    Dynarec.Enabled = 1
    Dynarec.idleskip = 1
    Dynarec.unstable-opt = 0
    aica.LimitFPS = 1
    aica.NoBatch = 0
    aica.NoSound = 0
    bios.UseReios = 0
    pvr.MaxThreads = 3
    pvr.Subdivide = 0
    pvr.SynchronousRendering = 0
    pvr.rend = 0
    rend.UseMipmaps = 1
    rend.WideScreen = 0
    ta.skip = 0
    enable_x11_keyboard = 1
    evdev_device_id_1 = 5
    evdev_device_id_2 = 6
    evdev_device_id_3 = -1
    evdev_device_id_4 = -1
    evdev_mapping_1 = /recalbox/share/system/configs/reicast/controllerP1.cfg
    evdev_mapping_2 = /recalbox/share/system/configs/reicast/controllerP2.cfg
    nox11 = 0
    ElfFile = 
    ta.HashCheckFile = 
    ta.HashLogFile = 
    OpenGlChecks = 0
    fullscreen = 0
    height = 480
    width = 640

  • Another issue (same hardware as previous post), this time with libcec not creating /dev/tty* for my usb cec adaptor. Possible udev issue (missing rule)?
    I have had this adaptor working on the last stable on another box.
    Thanks again.

    # dmesg | grep -i cec
    [    1.943138] usb 1-4: Product: CEC Adapter
    [    3.267137] input: Pulse-Eight CEC Adapter as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.2/0003:2548:1002.0001/input/input14
    [    3.267239] hid-generic 0003:2548:1002.0001: input,hidraw0: USB HID v1.10 Mouse [Pulse-Eight CEC Adapter] on usb-0000:00:14.0-4/input2
    # cec-client
    No device type given. Using 'recording device'
    CEC Parser created - libCEC version 4.0.2
    no serial port given. trying autodetect:
     path:     /sys/devices/pci0000:00/0000:00:14.0/usb1/1-4
     com port: /sys/devices/pci0000:00/0000:00:14.0/usb1/1-4
    opening a connection to the CEC adapter...
    DEBUG:   [              11]     Broadcast (F): osd name set to 'Broadcast'
    ERROR:   [            3514]     error opening serial port '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4': Is a directory
    ERROR:   [            3514]     could not open a connection (try 1)
    ERROR:   [            6349]     error opening serial port '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4': Is a directory
    ERROR:   [            6349]     could not open a connection (try 2)
    ERROR:   [            8239]     error opening serial port '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4': Is a directory
    ERROR:   [            8239]     could not open a connection (try 3)
    ERROR:   [            9499]     error opening serial port '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4': Is a directory
    ERROR:   [            9499]     could not open a connection (try 4)
    unable to open the device on port /sys/devices/pci0000:00/0000:00:14.0/usb1/1-4
    NOTICE:  [           10504]     connection opened
    ERROR:   [           10504]     could not start CEC communications

  • Je suis en test avec la nouvelle version beta "February 2019 Beta Version". Bravo la team, que de boulot dans cette nouvelle beta.

    • Comment peut-on désactiver l'indication de compteur de Frames qui défile en bas à gauche de chaque lancement de jeu quelques soit les consoles ?
    • Pour les bios, il y en a des nouveaux à rajouter. Par contre dans le "Recalbox Manager", il me semble ne plus voir d'ancien BIOS qui apparaissaient avant. Est-ce normal ? Si oui, ceux qui n'apparaissent plus, il faut les supprimer ?

  • Moderator

    @gnubit Thanks for your feedback, we'll take a look as soon as possible on both issues.

    @simba51 AFAIK, only old Amiga BIOS are no longer used (kick13.rom, kick20.rom & kick30.rom)

Log in to reply

Want to support us ?

Join us on :





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.