Amiga 50Hz



  • Bonjour à tous,

    J'aimerais savoir quelles lignes à ajouter au fichier conf pour que Amiberry tourne en 50 Hz afin d'avoir des jeux fluides. J'ai chercher un peu partout et essayer mais rien y fait.
    Si vous avez la solution ce serait gentil de me l'indiquer.
    A bientôt


  • Staff
    Screenscraper
    Developer
    Global moderator
    Team

    Ca va dependre, de l'emulateur, des jeux que tu fais tourner, et du hardware que tu utilises.
    Tu es sur quoi? Pi3? Autre?



  • Salut,

    Je pense que l'émulateur est Amberry, je suis sur recalbox xmas avec un pi3+.


  • Staff
    Screenscraper
    Developer
    Global moderator
    Team

    Amiberry, sur un 3B+, normalement, sauf bug, tous les jeux tournent déjà à leur maximum 🙂



  • Je vous remercie d'avoir répondu et d'essayer de m'aider.

    Ce n'est pas le fait qu'il tourne à son maximum, c'est qu'il tourne en 60Hz et l'Amiga de l'époque en version européenne était en 50Hz d'où un décalage dans le scrolling des jeux. Ce que je souhaite c'est la ligne de commande à écrire dans le fichier recalbox.conf afin de faire tourner l'émulateur en 50Hz. Je suppose que c'est une ligne de commande comme par exemple:
    "amiga1200.videomode=CEA 19 HDMI" qui serait normalement du 720p 50.
    Voici un tableau représentant les différents mode HDMI:http://trycatch.fr/raspberry-pi-sortie-hdmi-cea-dmt/
    J'espère qu'il y a une solution. A bientôt


  • Banned

    @acehigh amiberry est encore un emulateur standalone même si il va vers l'integration avec libretro, les paramètres dont tu parles sont généralement mappés avec des param libretro.

    As tu regardé dans le GUI de libretro si on peut sélectionner un mode 50 ou 60hz ?

    Si non, il faut voir avec l'équipe de amiberry sur leur github


  • Staff
    Screenscraper
    Developer
    Global moderator
    Team

    @acehigh Le NTSC n'est pas activé par defaut, donc... a priori la vitesse de balayage emulé est 50hz.
    Par contre je ne comprends pas le " d'où un décalage dans le scrolling des jeux".
    PAL ou NTSC, ça ne provoque qu'une différence dans la vitesse globale des jeux, rien de plus.


  • Banned

    @bkg2k J'ai déjà eu une grosse prise de tête sur le sujet avec un utilisateur au début où j'ai implémenté amiberry, où il m'avait montré 4-5 captures videos de jeu avec des problèmes de saccade selon lui.

    Perso y'en a qu'une ou je voyais un peu quelque chose de saccadé, et encore il fallait que me force...

    Mais bon a priori l'issue existe, par contre je croyais qu'elle avait été fixé dans amiberry il y a un moment


  • Staff
    Screenscraper
    Developer
    Global moderator
    Team

    Faut attendre la prochaine beta/stable alors 🙂



  • Bonjour à tous,

    J'ai enfin réussi à faire tourner l'émulateur en 50hz en modifiant cette ligne dans le fichier recalbox.conf.
    global.videomode=CEA 4 HDMI, j'ai remplacer le 4 par 19 (resolution 720p 50Hz). Je vous assure qu'il y a une différence notable en jeu ex: Wrath of the demon enfin fluide.
    Le problème c'est que tous les émulateurs sont en 50Hz avec cette solution. Ce que j'aimerais c'est avoir une ligne de commande uniquement pour l'amiga, j'ai beau chercher je ne connais pas le nom exact de cette commande. Ex pour la Snes c'est snes.videomode=CEA 4 HDMI.
    Si quelqu'un a la solution, ce serait vraiment gentil.
    A bientôt.

    PS: je suis sur la beta de février.


  • Banned

    @acehigh essaye avec amiga600 ou amiga1200 à la place de snes



  • @AceHigh Merci !!! Tu a résolu mon problème avec le C64 ! Effectivement les émulateurs tournent en 50hz mais l'écran lui est rafraîchi en 60hz et donc ça donne des scrollings saccadés.
    Pour les machines qui tournent en 50hz il faut ajouter ceci dans recalbox.conf :

    c64.videomode=CEA 19 HDMI
    atarist.videomode=CEA 19 HDMI
    amiga600.videomode=CEA 19 HDMI
    amiga1200.videomode=CEA 19 HDMI
    amstradcpc.videomode=CEA 19 HDMI
    thomson.videomode=CEA 19 HDMI

    Je n'ai pas pu testé l'amiga car la je suis sur la version stable mais pour les autres ça marche parfaitement 🙂



  • Merci voljega et Secamfr,

    Grâce à vous j'ai sû résoudre mon problème.
    En résumé j'ai écris cette ligne "amiga1200.vedomode=CEA 19 HDMI" juste au dessus de la ligne Snes comme ceci:

    ------------ I - EMULATORS CHOICES -----------

    You can override the global configuration here

    Here is the snes example

    amiga1200.videomode=CEA 19 HDMI
    ;snes.videomode=CEA 4 HDMI
    snes.core=snes9x_next
    ;snes.shaders=/recalbox/share/shaders/shaders_glsl/mysnesshader.gplsp

    J'ai fais cette modification via le manager Recalbox qui est bien pratique.

    Encore un grand merci et bon jeu.

    A Bientôt


Log in to reply
 

Want to support us ?

269
Online

80.5k
Users

21.6k
Topics

157.9k
Posts