Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[Non officiel] Recalbox PC x86_64 avec les drivers Nvidia !!


  • Staff
    Moderator
    Netplay

    @chris256 non désoler je vient de regarder ne t’ennuie pas a tester cette version car je prépare une nouvelle sur la mise a jour bêta sorti aujourd’hui pour la n64 j'ai le même soucis que toi je te propose un nouveau test avec la nouvelle version d'ici peut



  • @strodown Ça marche ! Merci pour le retour rapide !



  • La même initiative pour les possesseurs de Radeon ? :sifflote:
    :D


  • Staff
    Moderator
    Netplay

    @zoroastre je vient a peine de m'y mettre donc voila j'ai déjà quelque soucis de compilation que je cherche a corriger sur le driver amd-catalyst pour linux je tiendrais la communauté informer !!
    ps: j'ai vu la demande de ces dernières semaine a ce sujet !!



  • @strodown said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    de compilation que je

    Merci pour ton temps et ton travail



  • @strodown Salut ! Alors tu as pu avancer sur la compilation d'une nouvelle version Nvidia à partir de la dernière beta ? Je suis dispo pour tester si besoin. Bonne journée !!



  • @strodown said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    @zeke déjà un grand merci pour ton retour détaillée
    le scraper devrait bientôt être remit sur pieds pour l'emulo gamecube qui plante en pause ce doit aussi être du a la partition share formater refait un test si tu peut !!
    oui dolphin fait des miracles niveau rendu graphique des jeux gamecube et autre

    Désolé pour mon manque de suivi mais je continu quelques tests malgré tout. Après réinstallation standard les scrapps fonctionnent bien. En revanche ma manette Xbox 360 Wireless ne fonctionne toujours pas sur Reicast. Seul le clavier fonctionne en utilisant le BIOS attendu dans RB Manager. Par ailleurs je ne parviens pas à afficher le menu des réglages de cet émulateur mais j’ai pas encore trop cherché de solution 😅

    Pour le moment j’ai testé pas mal de jeux GameCube & PSP avec succès, si ce n’est le petit bug d’affichage déjà remonté (le trait horizontal dans le tiers supérieur de l’image). Mais peut-être que l’update de Février corrigera ces petits kwaks.

    @strodown said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    @zeke déjà un grand merci pour ton retour détaillée
    le scraper devrait bientôt être remit sur pieds pour l'emulo gamecube qui plante en pause ce doit aussi être du a la partition share formater refait un test si tu peut !!
    oui dolphin fait des miracles niveau rendu graphique des jeux gamecube et autre


  • Staff
    Moderator
    Netplay

    @zeke pas de soucis

    • l’émulateur reicast présent actuellement n'est pas un core libretro donc pas de menu d'option
    • pour le soucis de pour le petit bug d'affichage c'est uniquement dans l'émulateur gamecube ou c'est aussi sur la psp
      sous dolphin il existe une option Vsync
      tu pourra activer cette option dans le fichier GFX.ini qui ce trouve dans :
      recalbox/share/system/configs/dolphin-emu/GFX.ini
    VSync = True
    

    tu modifie comme ça puis enregistre et test !!


  • Staff
    Moderator
    Netplay

    @chris256 oui le lien est disponible en haut de page



  • @strodown Merci pour cette nouvelle version ! Alors je viens de tester et voici quelques retours :

    • la (ou le ;-)) gamecube marche super bien !
    • les jeux retroarch se lancent bien
    • sur la dreamcast, l'écran de réglage de la date est comme figé (mais je crois que c'est un bug de la beta non ?)
    • par contre dès que je lance un jeu N64, je reviens immédiatement sur ES. Voici une archive support :
      https://file.ac/yYXbLep_3TI/

    À part la n64, de gros progrès sur ma configuration en tout cas... Bravo !

    Si je peux aider à tester pour la n64, n'hésite pas.


  • Staff
    Moderator
    Netplay

    @chris256 pour la n64 j'ai pas encore eux le temp de me pencher reelement sur le sujet dans tes logs j'ai vu ceci :
    The resolution for 'CEA 1 HDMI' is not supported by your monitor
    tu peut voir pour changer ce mode dans ton fichier recalbox.conf

    ## Set game resolution for emulators
    ## Please don't modify this setting
    ## This arch does not support the video mode switch
    ## (string)
    ##global.videomode=CEA 1 HDMI
    
    global.videomode=DMT 35 HDMI
    
    

    tu a aura plus d'info ici :
    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)


  • Staff
    Moderator
    Netplay

    salut a tous
    j'aurais besoin de testeur pour un script !
    ceux qui veulent bien le faire merci de venir en message priver sur le forum ou sur le discord de recalbox merci d'avance !!!!



  • @strodown said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)

    Salut !

    Je viens de changer comme indiqué. J'ai rebooté mais toujours le retour sous ES quand je lance un jeu N64. Voici une nouvelle archive support juste après avoir lancé un jeu N64 :
    https://file.ac/CyV5mCKGez8/

    Merci pour ton aide !


  • Staff
    Moderator
    Netplay

    @chris256 test ceci stp
    dans une fenêtre putty connecter en ssh a ta recalbox
    une fois log tu tape

    export DISPLAY=:0

    mupen64plus --resolution 1280x1024 /recalbox/share/roms/n64/
    tu ajoute le nom de ta rom au bout tu peut aussi adapter la résolution a ton écran
    pour moi ça donne :
    mupen64plus --resolution 1280x1024 /recalbox/share/roms/n64/007\ -\ GoldenEye\ \(Europe\).n64
    donne moi le retour assez vite merci



  • @strodown alors j'ai essayé mupen64plus --resolution 1024x768 /recalbox/share/roms/n64/007\ -\ GoldenEye\ \(USA\).z64 et voici le résultat :

     __  __                         __   _  _   ____  _             
    |  \/  |_   _ _ __   ___ _ __  / /_ | || | |  _ \| |_   _ ___ 
    | |\/| | | | | '_ \ / _ \ '_ \| '_ \| || |_| |_) | | | | / __|  
    | |  | | |_| | |_) |  __/ | | | (_) |__   _|  __/| | |_| \__ \  
    |_|  |_|\__,_| .__/ \___|_| |_|\___/   |_| |_|   |_|\__,_|___/  
                 |_|         http://code.google.com/p/mupen64plus/  
    Mupen64Plus Console User-Interface Version 2.5.0
    
    UI-Console Error: dlopen('./libmupen64plus.so.2') failed: ./libmupen64plus.so.2: cannot open shared object file: No such file or directory
    UI-Console Error: AttachCoreLib() Error: failed to find Mupen64Plus Core library
    

    PS : désolé du retard, je n'ai pas pu le faire plus tôt...


  • Staff
    Moderator
    Netplay

    @chris256 nos problème
    alors voici la solution a ce soucis
    toujours dan ton terminal tu tape
    mount -o remount, rw / ensuite
    ln -sf /usr/lib/libmupen64plus.so.2.0.0 /usr/lib/libmupen64plus.so.2
    refait un test par la suite !!!
    tu peut avoir le support de la manette avec cette commande :
    mupen64plus --resolution 1024x768 -p1index 0 -p1guid 03000000790000000018000011010000 -p1name "HJZ Mayflash WiiU Pro Game Controller Adapter" -p1nbaxes 4 -p1devicepath /dev/input/event2 /recalbox/share/roms/n64/007\ -\ GoldenEye\ \(USA\).z64



  • @strodown Merci pour ta réponse ! Alors cette fois ça se lance, j'ai l'image mais pas de manette et pas de son. Voici ce que j'ai dans la console :

    mupen64plus --resolution 1920x1080 -p1index 0 -p1guid 03000000790000000018000011010000 -p1name "HJZ Mayflash WiiU Pro Game Controller Adapter" -p1nbaxes 4 -p1devicepath /dev/input/event2 /recalbox/share/roms/n64/007\ -\ GoldenEye\ \(USA\).z64
     __  __                         __   _  _   ____  _             
    |  \/  |_   _ _ __   ___ _ __  / /_ | || | |  _ \| |_   _ ___ 
    | |\/| | | | | '_ \ / _ \ '_ \| '_ \| || |_| |_) | | | | / __|  
    | |  | | |_| | |_) |  __/ | | | (_) |__   _|  __/| | |_| \__ \  
    |_|  |_|\__,_| .__/ \___|_| |_|\___/   |_| |_|   |_|\__,_|___/  
                 |_|         http://code.google.com/p/mupen64plus/  
    Mupen64Plus Console User-Interface Version 2.5.0
    
    UI-Console: attached to core library 'Mupen64Plus Core' version 2.5.0
    UI-Console:             Includes support for Dynamic Recompiler.
    Core Error: Unable to open rom database file '(null)'.
    UI-Console Warning: unrecognized command-line parameter '-p1index'
    UI-Console Warning: unrecognized command-line parameter '0'
    UI-Console Warning: unrecognized command-line parameter '-p1guid'
    UI-Console Warning: unrecognized command-line parameter '03000000790000000018000011010000'
    UI-Console Warning: unrecognized command-line parameter '-p1name'
    UI-Console Warning: unrecognized command-line parameter 'HJZ Mayflash WiiU Pro Game Controller Adapter'
    UI-Console Warning: unrecognized command-line parameter '-p1nbaxes'
    UI-Console Warning: unrecognized command-line parameter '4'
    UI-Console Warning: unrecognized command-line parameter '-p1devicepath'
    UI-Console Warning: unrecognized command-line parameter '/dev/input/event2'
    Core: Goodname: GOLDENEYE (unknown rom)
    Core: Name: GOLDENEYE           
    Core: MD5: 70C525880240C1E838B8B1BE35666C3B
    Core: CRC: DCBC50D1 9FD1AA3
    Core: Imagetype: .z64 (native)
    Core: Rom size: 12582912 bytes (or 12 Mb or 96 Megabits)
    Core: Version: 1447
    Core: Manufacturer: Nintendo
    Core: Country: USA
    UI-Console Status: Cheat codes disabled.
    UI-Console: using Video plugin: 'Glide64mk2 Video Plugin' v2.5.0
    UI-Console: using Audio plugin: 'Mupen64Plus SDL Audio Plugin' v2.5.0
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    UI-Console: using Input plugin: 'Mupen64Plus SDL Input Plugin' v2.5.0
    UI-Console: using RSP plugin: 'Hacktarux/Azimer High-Level Emulation RSP Plugin' v2.5.0
    Video: opening /usr/share/mupen64plus/Glide64mk2.ini
    
    INI_FindSection trying to find name for DEFAULT
    Input: 4 SDL joysticks were found.
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input Error: No auto-config found for joystick named 'HJZ Mayflash WiiU Pro Game Controller Adapter' in InputAutoConfig.ini
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input Error: No auto-config found for joystick named 'HJZ Mayflash WiiU Pro Game Controller Adapter' in InputAutoConfig.ini
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input Error: No auto-config found for joystick named 'HJZ Mayflash WiiU Pro Game Controller Adapter' in InputAutoConfig.ini
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input Error: No auto-config found for joystick named 'HJZ Mayflash WiiU Pro Game Controller Adapter' in InputAutoConfig.ini
    Input: N64 Controller #1: Forcing default keyboard configuration
    Input: Using auto-config file at: '/usr/share/mupen64plus/InputAutoCfg.ini'
    Input: 1 controller(s) found, 1 plugged in and usable in the emulator
    Input Warning: Couldn't open rumble support for joystick #1
    Input Warning: Couldn't open rumble support for joystick #2
    Input Warning: Couldn't open rumble support for joystick #3
    Input Warning: Couldn't open rumble support for joystick #4
    Input: Mupen64Plus SDL Input Plugin version 2.5.0 initialized.
    INI_FindSection trying to find name for DEFAULT
    INI_FindSection trying to find name for GOLDENEYE
    Video: Using TEXUMA extension.
    
    &ConfigOpenSection is 0x7f0badf76668
    (II) Setting video mode 1920x1080...
    Core: Setting video mode: 1920x1080
    Congratulations, you have 4 auxilliary buffers, we'll use them wisely !
    packed pixels extension used
    NPOT extension used
    use_fbo 1
    Video: InitCombine() 
    Video: extensions 
    Video: initialized.
    Video: 
    
    Audio: Initializing SDL audio subsystem...
    Audio Error: Couldn't open audio: ALSA: Couldn't open audio device: Device or resource busy
    Input Warning: Couldn't open rumble support for joystick #1
    Input Warning: Couldn't open rumble support for joystick #2
    Input Warning: Couldn't open rumble support for joystick #3
    Input Warning: Couldn't open rumble support for joystick #4
    Core Error: Could not construct face from (null)
    Core: Starting R4300 emulator: Dynamic Recompiler
    Core: R4300: starting 64-bit dynamic recompiler at: 0x7f0bbc2ec0a0
    INI_FindSection trying to find name for UCODE
    Core Status: Stopping emulation.
    Core: R4300 emulator finished.
    Core Status: Rom closed.
    

    PS : j'ai testé en relançant ensuite depuis l'interface mais là ça ne se lance pas. Je dois passer par la console (j'avais testé au cas où le lien ln que tu as donné règle aussi le problème depuis ES). Merci beaucoup pour ton aide ! Je sens qu'on y est presque
    PPS : je ne suis pas chez moi aujourd'hui mais je pourrai tester ce soir autre chose si tu as une idée...



  • Configuration testée :

    • MBA SoAM4 ASUS PRIME A320M-K
    • CPU AMD AM4 Ryzen 5 2600 6x3.40GHz
    • RAM DDR4-3000 8GB PC4-24000U G.Skill Aegis
    • VGP NVIDIA Gainward GeForce GTX 1070 8GB 3750
    • Manette PS4 raccordée en filaire
    • casque sur sortie audio analogique
      => tout semble fonctionner correctement (je n'ai testé que les jeux sur l'image) contrairement à la verison beta officielle qui est horriblement lente.

    Merci beaucoup pour cette version ;)


  • Staff
    Moderator
    Netplay

    MISE A JOUR DE LA VERSION
    le 29/02/19
    Après quelque mésaventure voici la dernier version de recalbox avec les drivers nvidia.

    • le driver est en version 396.45
      liste des GPU
      lien de téléchargement de l'image

    • le lien symbolique manquant a l’émulateur mupen64plus (libmupen64plus.so.2) a était corriger cependant l'emulateur ne ce lance toujours pas depuis le menu EmulationStation un problème dans le conffigen persiste que je ne sais corriger!!!

    @strodown said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    @chris256 pour la n64 j'ai pas encore eux le temp de me pencher reelement sur le sujet dans tes logs j'ai vu ceci :
    The resolution for 'CEA 1 HDMI' is not supported by your monitor
    tu peut voir pour changer ce mode dans ton fichier recalbox.conf

    ## Set game resolution for emulators
    ## Please don't modify this setting
    ## This arch does not support the video mode switch
    ## (string)
    ##global.videomode=CEA 1 HDMI
    
    global.videomode=DMT 35 HDMI
    
    

    tu a aura plus d'info ici :
    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)

    • lspci a était mis a jour sur une version plus riche en information afin de mieux identifier la carte graphique et autre composant de la machine

    MERCI DE ME DONNER LE RÉSULTAT DE CETTE COMMANDE !!!!!
    lspci -s 01:00

    voila ce qui apparaît pour ma carte

    # lspci -s 01:00
    01:00.0 VGA compatible controller: NVIDIA Corporation GP108 [GeForce GT 1030] (rev a1)
    01:00.1 Audio device: NVIDIA Corporation GP108 High Definition Audio Controller (rev a1)
    


  • Salut @strodown !

    Alors je viens de tester la nouvelle version. Voici quelques retours :

    1. La gamecube marche toujours aussi bien !
    2. La dreamcast marche à présent !
    3. Toujours pas de souci sous retroarch (j'ai pas tout testé mais SNES marche par exemple)
    4. Par contre je confirme qu'il y a toujours un souci pour la N64, je reviens de suite à ES après avoir lancé un jeu...

    Sinon j'ai lancé la commande lspci -s 01:00 comme demandé et voici ce que j'obtiens :

    01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
    01:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)
    

    Merci encore pour ton travail !! J'espère vraiment qu'une solution pourra être trouvée pour la N64 car c'est vraiment le seul truc qui manque...



Want to support us ?

165
Online

55416
Users

18174
Topics

136813
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.