Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[Non officiel] Recalbox PC x86_64 avec les drivers Nvidia !!



  • @strodown It seems that this folder is read only (nano says [ Error writing /usr/share/X11/xorg.conf.d/50-card.conf: Read-only file system ]). I tried mount -o remount, rw /usr/share/X11 but I have error mount: mounting rw on /usr/share/X11 failed: Invalid argument (sorry I am not very skilled at this)



  • @chris256 Sorry, mount -o remount,rw / did the trick


  • Staff
    Moderator
    Netplay

    @chris256 nn only mount -o remount, rw /


  • Staff
    Moderator
    Netplay

    @strodown no pb



  • @strodown I also confirm that file libglx.so.410.73 is missing so I dit the instruction that you asked. I am rebooting right now...



  • @strodown After reboot I have Booting Recalbox forever on screen so I rebooted in verbose mode and I have xinit : giving up unable to connect to X server: Connection refused server error. Here is the log.

    In the directory I have those files:
    lrwxrwxrwx 1 root root 16 Jan 20 20:49 libglx.so -> libglx.so.410.73
    lrwxrwxrwx 1 root root 29 Nov 22 14:17 libglxserver_nvidia.so -> libglxserver_nvidia.so.410.73
    lrwxrwxrwx 1 root root 29 Nov 22 14:17 libglxserver_nvidia.so.1 -> libglxserver_nvidia.so.410.73
    -rw-r--r-- 1 root root 14997128 Nov 22 16:14 libglxserver_nvidia.so.410.73


  • Staff
    Moderator
    Netplay

    @chris256 delete the 50-card.conf file I can not help anymore because libglx.so.410.73 is not present in this driver version. desolate for the moment it will be necessary to wait the time that I create the new image on the last beta in date still thanks for your tests



  • @strodown OK. Top bad. I’’try to check this topic regularly. If I can be of any help, please tell me!



  • Un grand merci à toi strodown...super taf !

    Pour ma part je suis agréablement surpris du résultat vu ma config :

    CM : MSI X399 SLI Plus
    CPU : AMD Threadripper 1900X
    RAM : 4x8Go Corsair Vengeance LPX 3200Mhz
    GPU : EVGA GeForce 1060 6Go

    J'ai peu le temps de tester ce soir mais j'affiche ES sur ma TV sans problème, pas de lenteur...et les petits plus de la bêta avec la nouvelle manette reconnue pour configuration immédiate. Il n'y a plus le bug du clavier invisible. Pour le moment RAS...c'est mon fils qui va être heureux :)


  • Staff
    Moderator
    Netplay

    @zeke good job merci du retour comme jeux test je propose zelda wind waker sur game cube
    si tu peut vérifier si les FPS sont stable il faut activer l’option dans le menu de dolphin hotkey et R2



  • Bonjour à tous,

    Malgré le petit souci détaillé plus haut pour les systèmes sous retroarch, j'ai continué à investiguer côté gamecube et je me suis rendu compte qu'avec ma config actuelle (AMD Phenom II 965 et carte graphique Nvidia 750Ti), j'ai des ralentissements importants par moments (qui se traduisent notamment par des micro-coupures dans le son). Changer la résolution n'a aucun effet (c'est pareil en résolution native ou en 1080p), ce qui me ferait penser que c'est dû au processeur, qu'en pensez-vous ?

    En cherchant un peu, j'ai vu que pour 70 euros je pourrais, sans changer de carte mère, passer à un AMD-FX-8350. Pensez-vous que dans ce cas les jeux gamecube passeraient sans problème ? À moins qu'il vaille mieux à l'heure actuelle carrément changer aussi la carte mère ?

    Voici un lien pour un comparatif entre ces CPU.

    Je suis preneur de tout conseil.

    Merci d'avance !


  • Staff
    Moderator
    Netplay

    @chris256 a tu test la dernière version ?
    je te conseille de faire une installation sur disk dur ça évite le soucis de partition share



  • @strodown Super ! Je n’avais pas vu qu’il y a une nouvelle version. Je ne rentre pas chez moi avant la semaine prochaine mais dès que je reviens, je fais un test et poste le résultat. Je croise les doigts pour l’integration !



  • @strodown PS : je n’ai pas tout suivi. Quel est le souci avec le fait d’utiliser une partition share ?


  • Staff
    Moderator
    Netplay

    @chris256 juste que pour mon cas quand je flashe sur une usb ma partition share ce monte pas je doit faire mon flash sur un dd



  • @strodown Je vais tester ça au plus vite.

    Pour info, j'ai un câble Display Port/HDMI qui part de la CG jusqu'à un ampli HC pour affichage sur TV. Sous Windows le son & l'image transite via ce cable, mais je ne suis pas surpris de n'avoir que le driver graphique pur sous RecalBox. La seule chose qui m’ennuie c'est de ne pas pouvoir tester la partie audio qui déconne pas mal avec la Christmas bêta sur RPI3B+ (notamment avec les jeux n64).

    Autre point mais probablement lié à une manip' que je ne devrais plus faire : Lors du démarrage de RecalBox en mode verbeux, je perd environ 1 minute sur le message suivant (x2) :

    xauth: timeout in locking authority file /recalbox/share/system /.Xauthority

    C'est très certainement lié au fait que j'ai formaté ma partition SHARE en FAT32 pour copier rapidement mes jeux depuis Windows. Sur la version RPI3 cette manip' m'empêche d'utiliser PuTTy donc je sais qu'elle n'est pas sans conséquences même si le système semble tout reconstruire sur la partition FAT32.

    Sinon je dois essayer pour la première fois les jeux WII, vérifier pourquoi les jeux Dreamcast ne se lancent plus, les jeux Atari5200 ne se lancent toujours pas. J'ai pas encore tester grand chose...

    Cotés positifs, les jeux Game Cube sont magnifiques et fluides en gameplay malgré de micro bugs d'affichage sur les cinématiques. Je suis en 16:9 automatiquement quand l'émulateur le permet comme avec la PSP. Sur cette dernière je n'ai pas les nombreux bugs rencontrés sur RPI3B+. Assasin's Creed Bloodlines est bluffant sur un écran 58 pouces !

    Bref, je continu un peu ce soir mais j'attaque sérieusement la semaine prochaine où j'aurai davantage de temps pour moi.



  • Salut @strodown !

    Je viens de tester et cette fois j'arrive à lancer les jeux retroarch ! Par contre le lancement prends bien 5 ou 6 secondes pour un simple jeu nes donc je pense qu'il y a un souci. Pour la dreamcast, ça a bien pris deux minutes avant d'avoir le menu de réglage de l'heure, je suis pas allé plus loin. Pour la N64, j'ai pas mal attendu mais je n'ai pas passé l'écran noir... C'était sur une seconde clé usb, je testerai avec une autre plus tard au cas où...


  • Staff
    Moderator
    Netplay

    @chris256 j'ai eu plusieurs soucis similaire pendant mes tests je te conseil une installation sur disque dur!!!



  • Salut @strodown ! Je testerai le disque dur plus tard (je n'ai pas de disque dédié pour l'instant). L'installation sur une autre clé usb a réglé le problème. Les jeux retroarch se lancent bien. Par contre, j'ai plusieurs choses à remonter :

    • sur les jeux n64, écran noir et retour immédiat à l'interface recalbox
    • sur les jeux dreamcast (en chd), j'arrive à l'écran de date que je suis obligé de valider avec le clavier car la manette ne semble pas fonctionner avec ce système puis retour à ES
    • sur gamecube : je vois les quelques images de début de jeu puis message d'erreur difficile à lire car vraiment tout petit ???CPU (peut-être IntelCPU) Unknown instruction 00000000 at PC=000000 last_PC=832... LR=802....

    Je ne sais pas si ça a un rapport mais mon processeur est un AMD. Voici une archive support :
    https://file.ac/XHd93vEGUhE/

    Bonne soirée !!



  • marche trop bien ! Trop GG !!!

    ma config :

    AMD Ryzen 5 1600X
    16 Go
    Nvidia 1070 driver 418.81



Want to support us ?

313
Online

55863
Users

18218
Topics

137134
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.