Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...)



  • Finally I've managed to update, I had to disable automatic updates too, to be able to update.

    The update literally broke everything, everything is playing extremely slow, boot-up videos are extremely slow.

    Games are playing half-speed or worse and audio is playing slow and buggy.

    The only thing that seems to work correctly is EmulationStation (except audio that is still slow and buggy).

    I'm using a CRT (720x576 @50hz)

    support file



  • Kodi behaves the same way... basically every scene in which there is sound seems to slowdown, maybe it's something related to the sound driver...

    I've disabled audio in the config.txt file and now games seems to move doble speed, Final Fantasy VIII (PAL) moves at 100FPS...

    Sonic 3 and Knuckles goes double speed too, N64 too...



  • I have updatet with the furst update link and after the update i have a black screen and the system does not reboot. Also i have the warning when i start an enulation or boot recalbox comes „ Under voltage detected“ and i cannot play my games from the external hard drive .



  • Successfully upgraded on RPi3B then moved micro SD card over to RPi3B+. Issues found:

    • After remapping Logitech F710 controller have no controller input in Kodi. Tried using keyboard to navigate Kodi to remap controller and while left/right keyboard cursor keys work, the up/down keyboard cursor keys cause it to appear like down cursor was held down.

    • msx2 gamelist.xml keeps getting zeroed out on a reboot or force update game list.

    • atarist games no longer run and just return to menu when launched.

    Here's the support archive although there were some errors running the script:

    /recalbox/scripts/recalbox-support.sh

    lspci: /sys/bus/pci/devices: No such file or directory
    /recalbox/scripts/recalbox-support.sh: line 53: aplay: command not found
    /recalbox/scripts/recalbox-support.sh: line 54: glxinfo: command not found
    /recalbox/scripts/recalbox-support.sh: line 55: xrandr: command not found
    /recalbox/scripts/recalbox-support.sh: line 56: xrandr: command not found

    https://www83.zippyshare.com/v/8UdGeDAk/file.html



  • @juakin dont do anything in ES. Or rather stop es in the webmanager, make the edit, the restart es



  • @betikito84 have at least read the 1st post of this topic ?



  • @juakin on which board are you running ? Pi ? Odroid ? PC ? As you're the only one with such problems, i believe it's something wrong on your side. Which customizations have you made ?

    try removing audio_pwm_mode=2



  • @mi7chy i have the same pad set in X-input mode, works perfect in kodi



  • @substring @olivierdroid92
    I have already solved the problem was the recalbox.conf file, which would be corrupt, I deleted it and remapped the gamepad.

    Thanks for your help.



  • @substring I'm running on a Pi3 (no plus), audio_pwm_mode it's actually disabled.
    But I've tried both, enable and disabled and none is working...

    #To get better sound through the composite output, enable the experimental audio driver for the raspberry pi
    #audio_pwm_mode=2

    If I leave audio on (dtparam=audio=on), I get this issue that whenever I get audio everything seems to slowdown, if I disable audio (#dtparam=audio=on) games seems to go double speed... ff8 100fps, etc.

    I've got a multiboot noobs SDCard, if I boot on Raspbian everything is working perfectly, so it's not a Pi3 issue.

    I'll leave the full config.txt here:
    config.txt



  • OK, I've continued testing and my assuptions are confirming one by one, as I told in an anterior post I was using a CRT-TV.

    When audio was on I suffered half-speed or worse, when audio was off, double-speed.

    So I thought maybe had something to do with analog output (composite audio for CRTs) and sound sincronization.
    So I just unplugged everything and went to my HD monitor (1080p) and tried to run the pi there...
    Everything worked perfectly, some minor slowdown on the zoom effect on ES when running a game (but something minor) and boot-up videos seemed a bit slow (but something minor, or maybe it's just me).
    Anyway games worked perfectly at fullspeed.

    So If I'm the only one having this issue maybe it's because I'm the only one testing with a CRT-TV, please check it out, thanks!

    I think there's something wrong with audio output (composite) and audio sincronization.

    • I've noticed another bug, when I choose the shutdown option from ES menu, the pi got stuck on the screen that shows the tiny recalbox logo and the version number, and never goes to full shutdown, you know, when the video output seems to disconnect, it seems to get stuck. I don't know if this has been reported already.

    Thanks for all your hard work!



  • @juakin thank you for the feedback. I've suggested you disable audio_pwm_mode, have you tried ?

    For ES : yeah, known but, though i javen't had a clue on it yet. I believe it's ES somehow crashing, i've exprienced this on some boards, but not everytime ... But i'm on it :)



  • @betikito84 donyou still have thay faulty file ? I'd need to dig why it was causing such trouble



  • @substring yes, I've tried both, disabled and enabled, but it doesn't solve the issue.



  • @juakin i'll check this, i have the cables and some CRT



  • @substring Salut !

    J'ai une carte RPI3B+ je test si tu cherche encore des testeurs. J'ai aussi un Tinker Asus !



  • @injall ben, y'a toujours besoin, y'a jamais trop d'avis ! Installe et dis nous tes impressions !



  • @juakin set audio_pwm_mode=0 and tadaaaaa



  • @substring that worked perfectly, thank you very much!

    It seems that the option "Refresh/update games list" makes ES crash too...
    For some reason I've lost N64 scrape data and I'm having some problems scraping again...



  • @juakin remove the gamelist file. The option does work, your file must have been corrupted



Want to support us ?

Join us on :

160
Online

42633
Users

17162
Topics

129019
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.