Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...)

  • @kimmykaroo i'd rather have you upgrade if you can, one of the main purpose is to test the upgrade process too as it has some major changes, i don't want to brick any recalbox

  • Hi ! I try the new release.
    I'm sorry, I will write in French, because my English is too bad to explain that happened!

    Donc, j'ai fait la maj bêta sur mon pi2.
    J'ai remap ma manette ps3 et j'ai d'abord voulu tester kodi, car j'avais un bug jusqu'à présent (la manette officielle ne fonctionait pas sur kodi avec le driver bluez 5). J'attendais la maj de kodi pour voir. Et bien sûr kodi 17, problème résolu.
    J'ai mis le stockage des Rom sur anyexternal et j'ai branché mon disque dur habituel avec ma configuration, mes roms, mes bios, saves...
    Mais je ne pouvais lancer aucun jeu, retour direct sur es.
    J'ai pensé au un problème du disque dur. J'ai donc fait une réparation sur Windows 10, et ça a marché !
    J'ai testé quelques jeux, qui ont fonctionné puis j'ai voulu retourner sur kodi. Et là, la manette ne fonctionnait plus. J'ai donc changé le driver pour shanwan via le Web manager et j'ai redémarré. A partir de la, c'était pire, puisque je ne pouvait plus lancer kodi non plus, ni aucun jeu, retour sur Es.
    J'ai éteint le pi et Remis ma sd avec mon système stable pour tester et écarter un problème vendu disque dur. Tout fonctionne très bien.

    Edit: pour le problème de manette sur kodi, c'est plus compliqué : avec le driver bluez5, sur la stable, la manette ps3 ne fonctionne pas sur kodi, que le disque dur soit branché ou non.
    Sur la beta, la manette ps3 fonctionne avec le driver bluez5 sur kodi, mais pas si le disque dur est branché. Ça vaudrait le coup que j'efface tous les fichiers de configuration présent sur le dd et que je ne garde que les dossiers Rom, save et bios (et éventuellement les thèmes) pour voir ce que ça donne.

  • OK, now, the system is stable. I had some freeze after wifi configuration (need to restart es by webmanager).
    In kodi, I pressed r2 to mute, but after is impossible to have sound back.
    Some time, after power off the systèm, Black screen. Need to power of by Web manager.
    No virtual keybord to do settings in es.

    But, no bigs troubles !

    (I'm sorry, my English is terrible !)

  • Ça fonctionne bien sur rpi 3b+ rien à dire pour le moment

  • I'm trying to edit to:

    but, it's not working, changes are made on the file, but as soon as I reboot it changes to:


    Update doesn't pop up and can't continue...

    I've everything as EXTERNAL, so the file is located in:

  • Hi. I have a 3 b + and every time I enter the game it returns to the game menu.
    In updates.type (https://review-507-bump-b-0jn0c0-archive-review-prod.recalbox.com)I have inserted the second line as indicated at the beginning and it does not update me. I do not know how I can solve it, I hope you help me.

    PS: Sorry for my English but I do not usually use it much.

  • Tester

    You need to re-map your pad.

  • Finally I've managed to update, I had to disable automatic updates too, to be able to update.

    The update literally broke everything, everything is playing extremely slow, boot-up videos are extremely slow.

    Games are playing half-speed or worse and audio is playing slow and buggy.

    The only thing that seems to work correctly is EmulationStation (except audio that is still slow and buggy).

    I'm using a CRT (720x576 @50hz)

    support file

  • Kodi behaves the same way... basically every scene in which there is sound seems to slowdown, maybe it's something related to the sound driver...

    I've disabled audio in the config.txt file and now games seems to move doble speed, Final Fantasy VIII (PAL) moves at 100FPS...

    Sonic 3 and Knuckles goes double speed too, N64 too...

  • I have updatet with the furst update link and after the update i have a black screen and the system does not reboot. Also i have the warning when i start an enulation or boot recalbox comes „ Under voltage detected“ and i cannot play my games from the external hard drive .

  • Successfully upgraded on RPi3B then moved micro SD card over to RPi3B+. Issues found:

    • After remapping Logitech F710 controller have no controller input in Kodi. Tried using keyboard to navigate Kodi to remap controller and while left/right keyboard cursor keys work, the up/down keyboard cursor keys cause it to appear like down cursor was held down.

    • msx2 gamelist.xml keeps getting zeroed out on a reboot or force update game list.

    • atarist games no longer run and just return to menu when launched.

    Here's the support archive although there were some errors running the script:


    lspci: /sys/bus/pci/devices: No such file or directory
    /recalbox/scripts/recalbox-support.sh: line 53: aplay: command not found
    /recalbox/scripts/recalbox-support.sh: line 54: glxinfo: command not found
    /recalbox/scripts/recalbox-support.sh: line 55: xrandr: command not found
    /recalbox/scripts/recalbox-support.sh: line 56: xrandr: command not found


  • @juakin dont do anything in ES. Or rather stop es in the webmanager, make the edit, the restart es

  • @betikito84 have at least read the 1st post of this topic ?

  • @juakin on which board are you running ? Pi ? Odroid ? PC ? As you're the only one with such problems, i believe it's something wrong on your side. Which customizations have you made ?

    try removing audio_pwm_mode=2

  • @mi7chy i have the same pad set in X-input mode, works perfect in kodi

  • @substring @olivierdroid92
    I have already solved the problem was the recalbox.conf file, which would be corrupt, I deleted it and remapped the gamepad.

    Thanks for your help.

  • @substring I'm running on a Pi3 (no plus), audio_pwm_mode it's actually disabled.
    But I've tried both, enable and disabled and none is working...

    #To get better sound through the composite output, enable the experimental audio driver for the raspberry pi

    If I leave audio on (dtparam=audio=on), I get this issue that whenever I get audio everything seems to slowdown, if I disable audio (#dtparam=audio=on) games seems to go double speed... ff8 100fps, etc.

    I've got a multiboot noobs SDCard, if I boot on Raspbian everything is working perfectly, so it's not a Pi3 issue.

    I'll leave the full config.txt here:

  • OK, I've continued testing and my assuptions are confirming one by one, as I told in an anterior post I was using a CRT-TV.

    When audio was on I suffered half-speed or worse, when audio was off, double-speed.

    So I thought maybe had something to do with analog output (composite audio for CRTs) and sound sincronization.
    So I just unplugged everything and went to my HD monitor (1080p) and tried to run the pi there...
    Everything worked perfectly, some minor slowdown on the zoom effect on ES when running a game (but something minor) and boot-up videos seemed a bit slow (but something minor, or maybe it's just me).
    Anyway games worked perfectly at fullspeed.

    So If I'm the only one having this issue maybe it's because I'm the only one testing with a CRT-TV, please check it out, thanks!

    I think there's something wrong with audio output (composite) and audio sincronization.

    • I've noticed another bug, when I choose the shutdown option from ES menu, the pi got stuck on the screen that shows the tiny recalbox logo and the version number, and never goes to full shutdown, you know, when the video output seems to disconnect, it seems to get stuck. I don't know if this has been reported already.

    Thanks for all your hard work!

  • @juakin thank you for the feedback. I've suggested you disable audio_pwm_mode, have you tried ?

    For ES : yeah, known but, though i javen't had a clue on it yet. I believe it's ES somehow crashing, i've exprienced this on some boards, but not everytime ... But i'm on it :)

  • @betikito84 donyou still have thay faulty file ? I'd need to dig why it was causing such trouble

Want to support us ?





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.