Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...)

  • et concernant le hash impossible ? ( ce qui bloque l'acces au online)

  • Hello! I bought a new Rasp 3b+ and seems to work perfect with XMas Beta


    1. Intellivision, everything is ok!
    2. Pokémon mini, everything is ok!
    3. Sufam Turboi, everything is ok!
    4. New Mame2003 Plus core, everything is ok! (downloaded correspondent romset)
    5. Kodi remap control, everything is ok! (I will try to install add-ons today)

    No problems with my USB PS2 clone gamepad.
    No problems with WI-FI (yesterday I used the Rasp about 10 hours transfering roms, without issues)

    Obviously I didn't try to scrap, because of the known bug, but I have a question about the double gamelist flie with .xml.xml extension, what is for?

    Thanks for the Recalbox system! Great job!

  • Bonjour à tous,
    En continuant les tests sur mon Rpi 3b+, j'ai rencontré quelques difficultés avec Kodi.
    J'utilise un pad PS3 en bluetooth et un carte SD SanDisk 32Go.
    Le pad PS3 est bien reconnu par recalbox et ne pose pas de problème lors des sessions de jeu.
    Dès que je lance Kodi, Kodi m'indique au démarrage qu'un nouveau périphérique est détecté et que je dois le configurer. Problème : le pad PS3 ne réagit pas et aucune action n'est possible => je suis contraint de relancer le Rpi pour pouvoir revenir à ES.
    J'ai testé avec un pad Sidewinder en usb : il est bien reconnu par recalbox et ne pose pas de problème dans les sessions de jeu.
    Impossible de lancer Kodi avec ce pad : écran noir avec la version de recalbox affiché en bas à gauche puis retour sur ES.
    Dans mon cas, Kodi est inutilisable avec la Beta sur Rpi 3b+.

  • @jorgemagana
    What‘s your Wifi setup? I‘m facing problems with Wifi:

    • Generally it takes a lot of time to connect after booting Recalbox. Sometimes even have to reboot for getting connected.
    • When using 2,4 Ghz band, having interferrences with Bluetooth gamepads. (Gamepads not working anymore in a distance > 2 meters)
    • When using 5 Ghz band no problems with bluetooth controllers, but still having same problems: Long delay or even reboot needed for connection,

    Using a Pi3 B+ with Christmas beta.

    Don‘t have these issues with Pi3 B and latest stable version. And also not with all of my other Wifi connected devices.

    Can confirm issues with game lists. Changing a game to another Emulation Core, for example N64 game to Rice in Metadata is not saved on my side, for example. Even though I haven‘t roms on external source. Everything is on MicroSD card.

    All tested Emulators are working fine so far:
    NES, SNES, N64, and PSX.

    Also new generation 8bitdo bluetooth controllers
    work perfectly with internal bluetooth of Pi3 B+!
    To all developers: Great work, please don‘t change anything on this side! :)

  • @lhari84 hello. I didn't change anything in wifi configuration, only gave a specific ip for recalbox in the router. That's all. The rasp connects to internet just few secondos after boot and remains like that all the time.

    I do not have a BT controller, so I can not confirm any issue.

    I need to test more game systems, just tested the new ones supported in the beta.

    I just finished trasfering all my roms a few minutes ago. I will test rest of the systems this weekend.

  • @xarana said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    @lexx @dalittlebosssam @kara45 I've got same issue for kodi even if you use "nfs" or "upnp" to select your storage.
    I tried first "upnp" but scrapping wasn't possible (the panel to select "The Movies Database" wasn't display)
    So I switched on a "nfs" share. Scrapping was available and start but crashed when finish.
    SSH connection is ok from my side.
    Using : RPI 3b+, 2018.12.24 Christmas.Beta, Powersupply 5V/3A, X-Box one wired pad,NAS Synology to mount "share"

    Après ce test KODI, je me suis intéressé à la partie Moonlight de cette version Christmas beta.
    Impossible de passer par le YOLO mode. Nécessité d’appairer le périphérique en utilisant le Hostname ou l'IP de la machine distante.
    ./Moonlight.sh pair (Hostname)
    Malgré cela la liste des titres est réaliser le scrapping s'effectue correctement, ./Moonlight.sh init (Hostname) puis Reboot.
    Moonlight apparaît correctement et propose ainsi la liste des jeux disponibles.
    On sélectionne un titre, le PC lance le titre mais malheureusement un écran noir apparaît coté TV. Les commandes du/des gamepad configuré ne fonctionne plus. C'est un black out complet, obligation de rebooter.
    Bon courage Recalbox et merci pour vos efforts.

  • Moderator

    Baisse la resolution de ton steam sur ton pc en 720p

  • Merci acris pour ton retour. Même en réglant les paramètres de diffusion steam sur 720p rien y fait. J'ai également testé d'autres titres dans la liste scrappé et ne faisant pas partie du portail steam avec le même résultat (écran noir pas de son non plus). Pas d'antivirus présent sur la machine.
    GFE : et connexion réseau Ethernet.

  • wifi is not connect .
    I was connecting to wifi when using the 18.07.13 version of the recalbox on the laptop. I installed Christmas.beta version of recalbox x86 18.12.24 a week ago but I can't connect to wifi. Even though I made a change to the recalbox.conf file, it didn't happen again, I don't know what else to do. device

    wifi device : Qualcomm Atheros AR9285 802.11b|g|n WiFi Ethernet 802.3

  • @lhari84 I can confirm that metadata is not saved. Changed the core and emulator, but information is not saved after reboot.

  • Hi,

    I'm new to Recalbox and to RPi's. I just bought a RPi 3B+. So I figured I'd try to install Recalbox and test it.

    I'm using the Christmas beta, and I have a 8bitdo N30 gamepad (not the Pro), with the latest firmware (4.1).

    The gamepad works in wired mode, but in bluetooth, it just refuses to pair. It is detected, but I always get the message "Unable to pair" after that. I don't have a BT dongle, I'm using the internal BT on the Pi.

    I tried starting the gamepad with Start, Start+R, Start+B, the result is always the same: detected in the list of BT devices, but attempting to pair it fails (quickly). I used the "forget controllers" option, I pressed Select for 3 seconds on the gamepad to forget previous pairing, nothing seems to work. For the record, the gamepad works in BT mode on Windows machines.

    Any ideas ?

    Other than that, Recalbox is really slick, boots quickly, the sound is working, and I played Classic Kong on the SNES without problems (with the wire). Everything else seems to work fine. So thanks for your work, devs :) .

  • @ced-le-pingouin
    Have you tried to reboot recalbox after forgetting bluetooth controllers? Remember I had to do this to pair one controller successfully.

  • Bonjour, je suis en test sur cette nouvelle version et je n'arrive pas à faire reconnaitre mon NAS avec celle-ci. En effet je possède 2 RECALBOX et j'ai upgradé (avec nouvelle installation) mon PI3 (l'autre est un PI2) et avec les mêmes paramètres pour le NAS (copier/coller) que mon PI2 en v18.07.13 il reste en local. Avez-vous une idée?
    Hello, i test this new revision and no roms with my NAS. Indeed i have 2 PI (2 and 3) and on my PI3 with this revision and the same network parameters (copy/paste) than my PI2 no roms on network (only view local roms). Do you have an idea?

  • Hey,

    I'm using the Christmas Beta on an Raspi 3B+ with a 32GB SD - no external storage devices.

    • My 8bitdo SF30 Pro Controller works without any problems on internal BT.
    • The shutdown script (Retroflag case) works but savegames are not written to SD, when switching off while still ingame (not sure if that's a script or recalbox problem)
    • Wifi takes a while to find and connect the AP, the first time but works well, afterwards.
    • Settings are not saved after exiting any emulator, I have to Hotkey+B every time I start a game. Even if I save the config in the menu, screen ratio will revert to "custom" after exiting the emulator.
    • N64 emulation is a bit laggy, sometimes, even when running on 1500MHz (using finned heatsinks on CPU and LAN, a copper heatspreader on ram and a 30mm fan in the case, so it shouldn't be a temp problem) - That's high-level moaning, however.

    If you need additional information, just ask.

  • @acris
    J'ai trouvé pourquoi. https://github.com/irtimmer/moonlight-embedded/issues/705
    Par contre je n'ai pas trouvé de listing avec les compatibilité moonligth / Version GFE
    J'ai donc testé la 3.15 et c'est fonctionnel. "Youpi"
    Je continu de tester...

  • Pi3+ everything is fine including Kodi (only one add one installed at the moment)

    The only problem is with NeoGeo. Several roms of romset are not working. I do not know if is a problem of the neogeo.zip bios or the roms (roms of romset didn't work anymore in beta). Every time crashes the system and had to disconnect from power otulet. Only one time after rebooted I received a message of ext4 error, then restarted and system started fine again. It happened only once.

    I noticed too that when one rom doesn't run, for example in FBA, I can not start another for example in Game Gear or Game Boy. After rebooting, I can run Game Gear or Game boy again.

  • Themer

    @jorgemagana FBA_libretro romset in beta ist still not

  • @voljega said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    @jorgemagana FBA_libretro romset in beta ist still not

    Thanks for answering.

    In FBA libretro with last stable version I had all installed roms working. With beta more than half did't work anymore. I had a veryfied romset.

    Same situation with NeoGeo folder.

    With beta none of the NeoGeo roms work anymore (with last stable all worked 100%)

  • I installed Christmas.beta version of recalbox x86 and x64 18.12.24 a week ago. I contacted and updated from the Ethernet but i did not proceed after the boot screen

  • @lhari84 Thanks for your answer.

    Yes I did reboot, multiple times. I actually tried several things. I even tried different available firmwares for the N30 gamepad, even older ones, but no luck...

    ...Until I tried to pair the gamepad "the hard way", i.e. manually, in the Linux console during an SSH session.

    Then it worked. For those interested, the process is described here : https://github.com/recalbox/recalbox-os/wiki/Connect-bluetooth-controller-manually-(EN)

    simple-agent did not work (method 1), but bluetoothctl did (method 2).

    I have no idea why it refuses to pair in the GUI. I tried so many times, and it never worked.

Want to support us ?

Join us on :





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.