Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...)

  • @caxelair I only tried PSX games, mostly FF7, and I had some "little" problems of pad freezing, hotkey button changing the shaders every time I pushed it etc. All that happened only after using the retroarch menu for configuration.

  • Hi, new to the forum but I've been using RecalBox for about ~4 years. Appreciate all the hard work the devs put in!

    My comment pertains to creating backup copies of the beta OS. I've tried using Win32 Disk Imager, HDD Raw Copy, and Roadkill's Disk Image on a Win7 x64 machine.
    Flashing a SD card with the backup copy (both with Etcher and the other imagers) results in an OS that has none of the saved roms and doesn't save configuration options across reboots (e.g., toogling overscan or saving a wifi network is reverted back to it's default state after a reboot). This is the same with editing through the GUI or through terminal (recalbox.conf).
    The only successful flashing I've had is taking the base img.xz file and using Etcher. This is driving me insane as it means the only way to make copies for another device is to redo all the work I did.

    I'm not sure if this is intentional as it's a beta version so the devs don't want misc copies spread everywhere or I'm doing something wrong. If you could, please let me know the recommended process for making backup copies. Is there a known method for Windows to make img.xz backups or is that only native to Linux?

  • Hi guys, first of all thanks for this x-mas version i couldn't test during these last days (to much activities with the family ;). Here's a little feedback of my own use (excuse my poor english)
    My harware : Rpi 3b+, SanDisk SDcard 1280 Go, NespiCase+

    • 8bitdo SF30 Pro gamepad works by USB cable + BT (couldn'u use the USB cable in the last OS version)
    • All my other pads (PS3 & PS4 official DualShock) works fine
    • I could set several themes, no soucy
    • I didn' t test my wifi co, but it was connecting so i think it must be the same

    I tested several machines, no soucy.

    Concerning the Amiga (Amiberry), in the last version, i could enter the GUI while pressing "start", then i couldn't go back to the game by clicking the "resume" button, the emu always freezed. This time no freeze, but when clicking the "resume" button, the Amiberry emulator is closing and i go back to the ES menu (amiga section of course). Also, the "select" button of my SF30 Pro pad can't quit the GUI either to go back to the game or to the ES menu. It has no use.

    This is what i can say about this version for instant.

    Once again, a big thank to the devs for your great work, keep it up mates :o)

  • Bonjour,

    J'ai des problèmes pour appairer les manettes PS4 en BT sur PI 3B+ et la version xmas de recalbox.

    Plus de détails sur le problème ici : https://forum.recalbox.com/topic/15684/test-beta-pour-pi-3b-appairage-manette-dualshock-4/13

  • Tested the new build on RPi3. There are some problem with Kodi, it work fine when no library created for Movie and TV Series. But if I try to scan library, it will go back to ES. After that, everytime I try to enter Kodi, it will return ti ES. It will work again after I deleted database file for Movies and TV. I have try remapping gamepad with 1 gamepad to 4 gamepad, remapping gamepad in Kodi, using only keyboard, using backup, copy database directly, but none seems to matter. Is there anyone with the same problem? Is there a solution?
    Also tested on RPi1, after a few minutes it will go black with ES logo on the bottom. Didnt manage to get to Kodi, and PS3 shanwan controller vibrate like crazy.

  • @invincible There's an issue with the scrapper (saving the images causes it to crash I think). Not really a fix but more of a workaround, while importing the library I just deselect the options that causes it to reach out for images and renaming.
    So what you're left with is just a readout of filenames from the server. It's kind of lame but works for the time being.

  • the memory card is read-only when installing the beta

  • Bonjour à tous,

    Je suis en cours de tests sur cette version beta sur un pi3 et je constate un bug sur les scrapping des jeux Megadrive. Les images sont correctement téléchargés dans le dossier downloaded_images mais le fichier gamelist.xml n'est ni créé ni modifié quand il y en a un existant.

  • Staff

    Merci le bug du scrap a ete maintefois signalé
    Le bug a ete identifie et devrait etre resolu dans la prochaine beta.

  • et concernant le hash impossible ? ( ce qui bloque l'acces au online)

  • Hello! I bought a new Rasp 3b+ and seems to work perfect with XMas Beta


    1. Intellivision, everything is ok!
    2. Pokémon mini, everything is ok!
    3. Sufam Turboi, everything is ok!
    4. New Mame2003 Plus core, everything is ok! (downloaded correspondent romset)
    5. Kodi remap control, everything is ok! (I will try to install add-ons today)

    No problems with my USB PS2 clone gamepad.
    No problems with WI-FI (yesterday I used the Rasp about 10 hours transfering roms, without issues)

    Obviously I didn't try to scrap, because of the known bug, but I have a question about the double gamelist flie with .xml.xml extension, what is for?

    Thanks for the Recalbox system! Great job!

  • Bonjour à tous,
    En continuant les tests sur mon Rpi 3b+, j'ai rencontré quelques difficultés avec Kodi.
    J'utilise un pad PS3 en bluetooth et un carte SD SanDisk 32Go.
    Le pad PS3 est bien reconnu par recalbox et ne pose pas de problème lors des sessions de jeu.
    Dès que je lance Kodi, Kodi m'indique au démarrage qu'un nouveau périphérique est détecté et que je dois le configurer. Problème : le pad PS3 ne réagit pas et aucune action n'est possible => je suis contraint de relancer le Rpi pour pouvoir revenir à ES.
    J'ai testé avec un pad Sidewinder en usb : il est bien reconnu par recalbox et ne pose pas de problème dans les sessions de jeu.
    Impossible de lancer Kodi avec ce pad : écran noir avec la version de recalbox affiché en bas à gauche puis retour sur ES.
    Dans mon cas, Kodi est inutilisable avec la Beta sur Rpi 3b+.

  • @jorgemagana
    What‘s your Wifi setup? I‘m facing problems with Wifi:

    • Generally it takes a lot of time to connect after booting Recalbox. Sometimes even have to reboot for getting connected.
    • When using 2,4 Ghz band, having interferrences with Bluetooth gamepads. (Gamepads not working anymore in a distance > 2 meters)
    • When using 5 Ghz band no problems with bluetooth controllers, but still having same problems: Long delay or even reboot needed for connection,

    Using a Pi3 B+ with Christmas beta.

    Don‘t have these issues with Pi3 B and latest stable version. And also not with all of my other Wifi connected devices.

    Can confirm issues with game lists. Changing a game to another Emulation Core, for example N64 game to Rice in Metadata is not saved on my side, for example. Even though I haven‘t roms on external source. Everything is on MicroSD card.

    All tested Emulators are working fine so far:
    NES, SNES, N64, and PSX.

    Also new generation 8bitdo bluetooth controllers
    work perfectly with internal bluetooth of Pi3 B+!
    To all developers: Great work, please don‘t change anything on this side! :)

  • @lhari84 hello. I didn't change anything in wifi configuration, only gave a specific ip for recalbox in the router. That's all. The rasp connects to internet just few secondos after boot and remains like that all the time.

    I do not have a BT controller, so I can not confirm any issue.

    I need to test more game systems, just tested the new ones supported in the beta.

    I just finished trasfering all my roms a few minutes ago. I will test rest of the systems this weekend.

  • @xarana said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    @lexx @dalittlebosssam @kara45 I've got same issue for kodi even if you use "nfs" or "upnp" to select your storage.
    I tried first "upnp" but scrapping wasn't possible (the panel to select "The Movies Database" wasn't display)
    So I switched on a "nfs" share. Scrapping was available and start but crashed when finish.
    SSH connection is ok from my side.
    Using : RPI 3b+, 2018.12.24 Christmas.Beta, Powersupply 5V/3A, X-Box one wired pad,NAS Synology to mount "share"

    Après ce test KODI, je me suis intéressé à la partie Moonlight de cette version Christmas beta.
    Impossible de passer par le YOLO mode. Nécessité d’appairer le périphérique en utilisant le Hostname ou l'IP de la machine distante.
    ./Moonlight.sh pair (Hostname)
    Malgré cela la liste des titres est réaliser le scrapping s'effectue correctement, ./Moonlight.sh init (Hostname) puis Reboot.
    Moonlight apparaît correctement et propose ainsi la liste des jeux disponibles.
    On sélectionne un titre, le PC lance le titre mais malheureusement un écran noir apparaît coté TV. Les commandes du/des gamepad configuré ne fonctionne plus. C'est un black out complet, obligation de rebooter.
    Bon courage Recalbox et merci pour vos efforts.

  • Staff

    Baisse la resolution de ton steam sur ton pc en 720p

  • Merci acris pour ton retour. Même en réglant les paramètres de diffusion steam sur 720p rien y fait. J'ai également testé d'autres titres dans la liste scrappé et ne faisant pas partie du portail steam avec le même résultat (écran noir pas de son non plus). Pas d'antivirus présent sur la machine.
    GFE : et connexion réseau Ethernet.

  • wifi is not connect .
    I was connecting to wifi when using the 18.07.13 version of the recalbox on the laptop. I installed Christmas.beta version of recalbox x86 18.12.24 a week ago but I can't connect to wifi. Even though I made a change to the recalbox.conf file, it didn't happen again, I don't know what else to do. device

    wifi device : Qualcomm Atheros AR9285 802.11b|g|n WiFi Ethernet 802.3

  • @lhari84 I can confirm that metadata is not saved. Changed the core and emulator, but information is not saved after reboot.

  • Hi,

    I'm new to Recalbox and to RPi's. I just bought a RPi 3B+. So I figured I'd try to install Recalbox and test it.

    I'm using the Christmas beta, and I have a 8bitdo N30 gamepad (not the Pro), with the latest firmware (4.1).

    The gamepad works in wired mode, but in bluetooth, it just refuses to pair. It is detected, but I always get the message "Unable to pair" after that. I don't have a BT dongle, I'm using the internal BT on the Pi.

    I tried starting the gamepad with Start, Start+R, Start+B, the result is always the same: detected in the list of BT devices, but attempting to pair it fails (quickly). I used the "forget controllers" option, I pressed Select for 3 seconds on the gamepad to forget previous pairing, nothing seems to work. For the record, the gamepad works in BT mode on Windows machines.

    Any ideas ?

    Other than that, Recalbox is really slick, boots quickly, the sound is working, and I played Classic Kong on the SNES without problems (with the wire). Everything else seems to work fine. So thanks for your work, devs :) .

Want to support us ?





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.