Recalbox 7.0

Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...)

  • @voljega Pour l'instant, le seul effet de bord est sur la gestion des mises à jour que j'ai désactivé. Cela fonctionne plutôt bien pour mon utilisation.

  • Salut,
    Problèmes rencontrés avec RPI3B+ et version Xmas:

    • Roms Dreamcast ne fonctionnent plus (fonctionnaient avec la version Beta précédente)
    • Scrapping ne marche plus
    • un fichier gamelist.xml.xml (double extension) apparait dans les dossiers roms (le fichier est rempli avec beaucoup de ligne vides puis quelques noeuds xml pour finir.
      Merci pour votre boulot. Vivement la stable !

  • Bonjour à tous

    je tente de configurer la NeoGeo CD sur la version Beta sortie à Noël.

    J'ai créé un dossier neogeocd dans le dossier Roms, ai placé les bios et dans le dossier bios.

    Rien n'est détecté. Mes jeux sont au format chd, aussi je me pose la question : est-ce que mon paramétrage est foireux ou alors est-ce le format de fichiers qui n'est pas bon ?

    Quelqu'un pourrait-il me donner quelques pistes ?

    Merci d'avance et meilleurs voeux à tous 🙂

  • Hi, and thanks a lot for this awesome work.

    Here's my configuration :
    Board : PI 3B+
    Version : 2018.12.24.Christmas.Beta
    SSD : 8GB
    HDD : 1TB
    AC : Official Raspi (2.5a) - I never have any lightning.

    Bugs reported so far :

    • Impossible to connect a Xbox One V2 (BT compatible) gamepad. It loads infinitely, and the pad stops itselfs. The system stays stuck on trying to connect.
    • Impossible to connect a PS4 gamepad. It loads then says "impossible to connect". This pads works without any problem on my Pi 3B with the stable version of July.
    • System freezes when I try to delete a game from the interface.
    • If I delete games coming with the release (i.e. DOOM), it comes back after a while. I tried through network and through the interface
    • Sometime, crashes when I unplug a pad connected with USB.
    • The bug on Nes stills here. I need to modify the retroarch config file to avoid cropped image.

    Hope this will help ! Thanks again !

  • Hi,
    Board PI 3B+
    Version : 2018.12.24.Christmas.Beta
    i'm trying to upload dreamcast bios
    with md5sum on recalbox
    e10c53c2f8b90bab96ead2d368858623 dc_boot.bin
    0a93f7940c455905bea6e392dfde92a4 dc_flash.bin

    but when i'm connecting on web interface for bios management I have
    dc_boot.bin e10c53c2f8b90bab96ead2d368858623 with ok tick
    dc_flash.bin d6e11a23f1fa01cddb5dfccf7e4cc8d7 with wrong tick

    this is not the same md5 but the dc_flash is good, i made a md5 before uploading it to recalbox and after and it's still 0a93f7940c455905bea6e392dfde92a4. Maybe a false positive on web interface ?
    But games doesn't start

    thanks !

  • Hey,
    My little feedback regarding this beta:

    • I had a hard time figuring out how to link my PS4 controller with the Recalbox. The solution was to unpair from the PS4 (go to settings, devices, then find your controller and unpair + delete it from another controller. Actually it's good to leave the console plugged so you will be sure that the controller is completely forgotten if when pressing PS button console doesn't turn on) before reseting and pair with Recalbox.
    • Wifi is working but super long (like 1'30) when SSID+key are entered and you close the menu
    • Ethernet is not working, I checked the wire, it's ok. Even with Kodi it's not recognized.

    Tested on:
    RPI 3 B +
    Samsung EVO Plus memory card 128GB
    BERLS Micro USB 5V 3000mA

  • @lexx @dalittlebosssam @kara45 I've got same issue for kodi even if you use "nfs" or "upnp" to select your storage.
    I tried first "upnp" but scrapping wasn't possible (the panel to select "The Movies Database" wasn't display)
    So I switched on a "nfs" share. Scrapping was available and start but crashed when finish.
    SSH connection is ok from my side.
    Using : RPI 3b+, 2018.12.24 Christmas.Beta, Powersupply 5V/3A, X-Box one wired pad,NAS Synology to mount "share"

  • @caxelair

    Thanks a lot for the tip, it worked for my PS4 controller ! I paired it back to my PS4, then forget it, and now it's working back on the 3B+ !

  • Global moderator

    @caxelair @Apoc

    all controllers used on other devices MUST be reset, it's not a bug, it's not an recalbox's issue but a user's issue

  • @apoc Happy to help mate 😉

    Btw, it worked on my v1 PS4 controller, don't know if yours was a v1 or a v2 (check if you have a light bar above the touch button, if yes v2)

    @acris sure, we know but in the tuto it's not specified. Plus, I never said it was a bug 😉
    So for you to be aware that the reset buton doesn't unpair all the time. 😉

    Edit: This 4min limit between 2 posts is a pain 😢

  • @acris I hadn't any problem with the PI 3B when I did that. Only the 3B+ had this issue. I always used the reset button back of the pad to do it.

    @caxelair both are V2 pads it seems !

  • @apoc Wonderful, so it works for both versions 😉
    Thanks for your feedback.

  • As I can't edit my original post, here some new feedback:

    • the scraper is not working which is quite frustating because we have the confirmation screen that everything is OK
    • GB/GBC/MD/NES/SNES are super smooth
    • n64 a bit laggy (on Super Smash Bros)
    • no lag with the ps4 controller

  • Hello. Great work! I love my Recalbox🕹. Why it takes much longer than other retrogaming systems for a stable release for RP3b+? Or is it a complete revision of all code, not just only for the RPI3B+ compatibility? 🤔

  • @caxelair I only tried PSX games, mostly FF7, and I had some "little" problems of pad freezing, hotkey button changing the shaders every time I pushed it etc. All that happened only after using the retroarch menu for configuration.

  • Hi, new to the forum but I've been using RecalBox for about ~4 years. Appreciate all the hard work the devs put in!

    My comment pertains to creating backup copies of the beta OS. I've tried using Win32 Disk Imager, HDD Raw Copy, and Roadkill's Disk Image on a Win7 x64 machine.
    Flashing a SD card with the backup copy (both with Etcher and the other imagers) results in an OS that has none of the saved roms and doesn't save configuration options across reboots (e.g., toogling overscan or saving a wifi network is reverted back to it's default state after a reboot). This is the same with editing through the GUI or through terminal (recalbox.conf).
    The only successful flashing I've had is taking the base img.xz file and using Etcher. This is driving me insane as it means the only way to make copies for another device is to redo all the work I did.

    I'm not sure if this is intentional as it's a beta version so the devs don't want misc copies spread everywhere or I'm doing something wrong. If you could, please let me know the recommended process for making backup copies. Is there a known method for Windows to make img.xz backups or is that only native to Linux?

  • Local Moderator

    Hi guys, first of all thanks for this x-mas version i couldn't test during these last days (to much activities with the family ;). Here's a little feedback of my own use (excuse my poor english)
    My harware : Rpi 3b+, SanDisk SDcard 1280 Go, NespiCase+

    • 8bitdo SF30 Pro gamepad works by USB cable + BT (couldn'u use the USB cable in the last OS version)
    • All my other pads (PS3 & PS4 official DualShock) works fine
    • I could set several themes, no soucy
    • I didn' t test my wifi co, but it was connecting so i think it must be the same

    I tested several machines, no soucy.

    Concerning the Amiga (Amiberry), in the last version, i could enter the GUI while pressing "start", then i couldn't go back to the game by clicking the "resume" button, the emu always freezed. This time no freeze, but when clicking the "resume" button, the Amiberry emulator is closing and i go back to the ES menu (amiga section of course). Also, the "select" button of my SF30 Pro pad can't quit the GUI either to go back to the game or to the ES menu. It has no use.

    This is what i can say about this version for instant.

    Once again, a big thank to the devs for your great work, keep it up mates 🐵

  • Bonjour,

    J'ai des problèmes pour appairer les manettes PS4 en BT sur PI 3B+ et la version xmas de recalbox.

    Plus de détails sur le problème ici :

  • Tested the new build on RPi3. There are some problem with Kodi, it work fine when no library created for Movie and TV Series. But if I try to scan library, it will go back to ES. After that, everytime I try to enter Kodi, it will return ti ES. It will work again after I deleted database file for Movies and TV. I have try remapping gamepad with 1 gamepad to 4 gamepad, remapping gamepad in Kodi, using only keyboard, using backup, copy database directly, but none seems to matter. Is there anyone with the same problem? Is there a solution?
    Also tested on RPi1, after a few minutes it will go black with ES logo on the bottom. Didnt manage to get to Kodi, and PS3 shanwan controller vibrate like crazy.

  • @invincible There's an issue with the scrapper (saving the images causes it to crash I think). Not really a fix but more of a workaround, while importing the library I just deselect the options that causes it to reach out for images and renaming.
    So what you're left with is just a readout of filenames from the server. It's kind of lame but works for the time being.

Want to support us ?