Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...)



  • @joinski THX very much for explaining for me.
    So, now you can delete your post.😉
    Very interesting story! 🧐


  • Developer
    Team
    Global moderator
    Translator

    @joinski @Pattick76 we never delete any posts here, only spam and such.
    And to be clear, recalbox is opensource and anyone can fork any part of the project, but people should always respect the license and give proper credit to the authors, that’s something some people are not capable to understand.
    This is not the place to such conversations so please keep within the topic.



  • @aerao Yop ^^ j'ai tout tenter mais a chaque fois il ne vois que 2go, mais ce n'est pas grave, javait une autre sd de 64go avec un disque dure usb de 2to et tout passe nikel ^^



  • Bonjour à tous,

    Comme beaucoup le scrap ES ne fonctionne pas et les favoris disparaissent à chaque reboot.
    Pourtant, les images relatives aux roms sont bien présentes dans le répertoire downloaded_images.
    Il semblerait que le problème tourne autour de l'écriture du fichier gamelist.xml (d'ailleurs, un fichier gamelist.xml.xml est également présent mais à quoi peu il servir ?) sur la carte SD.
    De même pour les favoris, la balise <favorite>true</favorite> ne peut être écrite puisque le fichier gamelist.xml ne contient pas les informations relatives aux roms.
    J'ai écris le fichier xml manuellement pour 2-3 roms histoire de tester : la balise <favorite>true</favorite> n'est pas écrite non plus lorsque j'ajoute une rom en favori depuis l'interface.
    Par contre, si je rajoute la balise <favorite>true</favorite> manuellement, alors ES en tient compte au prochain reboot.
    Pas d'infos dans les logs concernant ce sujet. Y a-t-il une option pour avoir un mode DEBUG et une log plus verbeuse ?



  • I'd like to report something with this beta release. Most times, I click on a game and it sends me back to the menu; doesn't matter what game it is. Restarting doesn't help, either.



  • @paradadf

    Ok, i understand.
    Sorry again for posting such a long text off topic.

    To come back to topic i want to tell you, what i noticed, when testing the PC-version (x64) of the christmas beta:
    My PS3 controller works out-of-the-box, all buttons work except for the hotkey and control within kodi. I had to remap the controller and after hat, hotkey works, but control within kodi still not.
    Did not test much more so far, but i will and i will then give further feedback.

    Is it ok, to post here some wishes/requests for further/more features?



  • @voljega said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    @phil333 said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    fter more then one hour testing with the new image I unplugged the cable and the controller then connected (a bit strange... ). on RPi 3B with the last image everything worked flawless. So there is a new bug.

    It's supposed to work like that, please at least read documentation

    @voljega Maybe I lost my ability to read during christmas, but where exacly in the documentation is written, that you have to connect a PS3 controller +1h via cable to get a BT connection?

    I said before that I tried it 20 times to connect...
    That includes the documented pairing process with cable etc. like I did on my RPi 3B before.
    Please just read a post entirely before you blame someone.


  • Developer
    Team
    Global moderator
    Translator

    @joinski this is not the place for feature requests either. Only report bugs and share archive supports 😉


  • Banned

    @phil333 said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    Maybe I lost my ability to read during christmas, but where exacly in the documentation is written, that you have to connect a PS3 controller +1h via cable to get a BT connection?

    https://github.com/recalbox/recalbox-os/wiki/Manual-(EN)#ps3controllers

    Your first message wasn't clear and led me to believe that you tried to pair the controller without cable or use it with cable.


  • Global moderator
    Team

    @Sp0oNy et autres personnes relatant le problème de scrap dans recalbox.

    C'est un bug provenant de Emulationstation, la team est entrain de l'identifier avec précision et corrigera le problème.

    Scraping ISSUE :
    This is a bug from Emulationstation, the team is identifying it with precision and will correct the problem.


  • Global moderator
    Team

    @godrick said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    Bonjour à tous,

    Comme beaucoup le scrap ES ne fonctionne pas et les favoris disparaissent à chaque reboot.
    Pourtant, les images relatives aux roms sont bien présentes dans le répertoire downloaded_images.
    Il semblerait que le problème tourne autour de l'écriture du fichier gamelist.xml (d'ailleurs, un fichier gamelist.xml.xml est également présent mais à quoi peu il servir ?) sur la carte SD.
    De même pour les favoris, la balise <favorite>true</favorite> ne peut être écrite puisque le fichier gamelist.xml ne contient pas les informations relatives aux roms.
    J'ai écris le fichier xml manuellement pour 2-3 roms histoire de tester : la balise <favorite>true</favorite> n'est pas écrite non plus lorsque j'ajoute une rom en favori depuis l'interface.
    Par contre, si je rajoute la balise <favorite>true</favorite> manuellement, alors ES en tient compte au prochain reboot.
    Pas d'infos dans les logs concernant ce sujet. Y a-t-il une option pour avoir un mode DEBUG et une log plus verbeuse ?

    il faut tuer le processus emulationstation pour effectuer des modifications sur une recalbox allumé , cette méthode est la même depuis la création de recalbox.



  • Ce matin en allumant ma recalbox manette plus détecter, je trouve déjà cela louche, je la refait association, je veut lancer un jeu mame, il ne fonctionne pas retour a liste des jeux, j'en relance un deuxième de même, je lance un un jeu SNES de même et ainsi que tout les emulateurs, alors que la veille cela marchais parfaitement bien... Sur Pi3B+


  • Banned

    @marco-polo si tu utilises une clé USB ou un HDD, répare la sous windows, sinon répare la partition share en SSH



  • @acris Pour être plus clair : j'ai modifié le fichier gamelist.xml manuellement puis lancer un "update game list" depuis l'interface de EmulationStation. Je suppose que cela équivaut exécuter la commande ssh /etc/init.d/S31emulationstation restart.
    Quoi qu'il en soit la prise en compte de modifications manuelles du fichier gamelist.xml ne pose pas de problème pour peu que l'on redémarre EmulationStation.
    Aucune modification sur le fichier gamelist.xml n'est effectué par EmulationStation depuis l'interface EmulationStation, que ce soit par le menu "edit this game's metadata" ou par l'ajout d'une rom en favoris.
    Un peu comme si EmulationStation n'avait pas les droits nécessaire sur le fichier pour le modifier.



  • @acris said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    @Sp0oNy et autres personnes relatant le problème de scrap dans recalbox.

    C'est un bug provenant de Emulationstation, la team est entrain de l'identifier avec précision et corrigera le problème.

    Scraping ISSUE :
    This is a bug from Emulationstation, the team is identifying it with precision and will correct the problem.

    @acris : cool, merci pour ton retour ! 🙂



  • J'ai continué à tester la parti concernant l'écriture du fichier gamelist.xml :

    • Création manuellement d'un fichier gamelist.xml concernant des informations sur 3 roms snes : le fichier est chargé correctement par EmulationStation.
    • Ajout d'un favori (une rom snes : Asterix & Obelix (E)) depuis l'interface EmulationStation.
    • Exécution de la commande /etc/init.d/S31emulationstation stop via ssh.
    • EmulationStation produit un fichier gamelist.xml.xml (l'extension apparaît 2 fois) avec les 3 roms snes initialement présente dans le fichier gamelist.xml puis y ajoute la balise ci-contre : <folder><path>&quot;./Asterix && Obelix (E).zip&quot;</path></folder> juste avant la balise </gameList>.
    • voici la log correspondante :
      lvl2: Saved gamelist.xml for system Super Nintendo Entertainment System. Updated items: 1/56
      lvl2: EmulationStation cleanly shutting down.
    • Exécution de la commande /etc/init.d/S31emulationstation start via ssh.
    • Le favoris a disparu : normal puisque EmulationStation charge le fichier gamelist.xml qui n'a pas été mise à jour (de toute façon la syntaxe dans le fichier gamelist.xml.xml n'est pas correcte).

    J'ai commencé à regarder du côté de la classe Gamelist.cpp mais je suis pas assez bon en C++ :

    /*
    * Write the list.
    * At this point, we're sure at least one node has been updated (or added and updated).
    */
    boost::filesystem::path xmlWritePath(system->getGamelistPath(true) + ".xml");
    boost::filesystem::create_directories(xmlWritePath.parent_path());
    try
    {
    pt::write_xml(xmlWritePath.generic_string(), document, std::locale("en_US.UTF8"));
    LOG(LogInfo) << "Saved gamelist.xml for system " << system->getFullName() << ". Updated items: " << fileLinks.size() << "/" << fileData.size();
    }
    catch (std::exception &e)
    {
    LOG(LogError) << "Failed to save " << xmlWritePath.generic_string() << " : " << e.what();
    }



  • First: happy new year everyone ! And now the issue I have encountered :
    I have tried many different themes and this as broken Emulationstation every time! For restoring this one I have using a file manager from my iPad and deleting the theme folder; then I have restarted Recalbox with the web interface...



  • Plus aucun émulateur ne fonctionne, je n'es rien toucher, juste l'association de ma 8bitdo nes pro, retour a la liste des jeux même après plusieurs reboot 😕
    Pi3B+ 64go+1 disque dure externe



  • Hi, happy new year. I dont know if there is a bug or just i dont know how to configure, but when i play mame games and i press up or down on the 1gamepad appear downscreen a quick menu of overclocking, bright...

    Cheers



  • hi there
    Happy new year to all

    using beta christmas edition

    when adding system to es_systems.cfg
    (for example adding cps1 cps2 cps3 using fba)
    then fba system disappear
    only latest system added in es_systems.cfg appears

    (btw: thoses lines added works on latest stable version)

    my lines added looks like this

    <system>
    <fullname>FBA_LIBRETRO</fullname>
    <name>fba_libretro</name>
    <path>/recalbox/share/roms/fba_libretro_cps2</path>
    <extension>.zip .ZIP .fba .FBA .7z .7Z</extension>
    <command>python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc %CONTROLLERSCONFIG% -system %SYSTEM% -rom %ROM% -emulator %EMULATOR% -core %CORE% -ratio %RATIO% %NETPLAY%</command>
    <platform>arcade</platform>
    <theme>fba_libretro_cps2</theme>
    <emulators>
      <emulator name="libretro">
        <cores>
          <core>fba</core>
        </cores>
      </emulator>
    </emulators>
    

    </system>

    so in this example,of course others are in the es_systems.cfg,but only the last system ,cps2, can be selected and visible
    others one (cps1/cps3 and of course fba) are invisible

    can someone confirm or i have done something wrong?



Want to support us ?

267
Online

78.1k
Users

19.9k
Topics

146.7k
Posts