Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...)



  • @voljega Le exFAT est supporté sans problème depuis windows 7 et même sous XP via une maj (tu as du te mélanger je pense :P).
    Le NTFS est un système journalisé donc le taux d'écriture/lecture sera plus élevé. Dans le cas de ta clé usb sous linux ça se traduira par une durée de vie amoindrie et par des performances en baisse par rapport à d'autres systèmes de fichiers (particulièrement visible avec un raspberry).
    Entre exFAT et FAT32 cela dépendra de son utilisation : si aucun fichiers ne dépasse 4Gb, FAT32 sera très bien (et parfaitement compatible). Sous windows exFAT est un peu plus performant que FAT32 mais sous linux / pi c'est à voir.



  • Bonjour à tous !

    Désolé de poster encore mais j'aimerais vraiment essayer quelque chose pour régler ce problème de son HDMI. J'ai installé recalbox version X84/64 dernière beta et, quel que soit ce que je choisis dans le menu audio comme sortie, je n'arrive pas à avoir de son sur HDMI (j'ai bien du son sous Windows via HDMI).
    Voici quelques lignes de log qui pourraient peut-être servir:

    • dans messages : input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input5
    • dans es_log : lvl0: VolumeControl::init() - Failed to find mixer elements!

    Je me souviens d'avoir lu quelque part qu'on peut en ligne de commande choisir sa sortie. Y-a-t'il une chance que ça aide ? Avez-vous un lien.

    PS : à moins que personne n'ait de son HDMI sur la version X86 de la dernière beta ?

    Merci beaucoup !!



  • Bonjour à tous,

    De mon côté je n'ai pas de probléme de son sur ma raspberry p3B+, branché en HDMI sur ma TV.

    super nouvelle pour cet update et merci à toute la communauté de nous faire bénéficier de ce super OS ! J'ai installé la version BETA de recallbox il y a 2 mois environ sur ma raspberry pi 3B+. Pour une BETA la version est stable et me permet de jouer à mes jeux PS1 favoris de mon enfance :) Cependant j'ai quelques rom qui ne fonctionne pas : Metal Gear Solid Disk 1 & 2, GEX 3, Crash Team Racing. J'ai essayé pas mal de versions différentes de ces roms mais rien ne change. Est-ce que cela est dû à la version beta svp ? La version finale peut'elle corriger ce soucis ? Petite derniére question, savez-vous quand la version finale va sortir svp ?

    Merci d'avance et bonne continuation pour ce super boulot !

    problème constaté : clavier disparaît dans certains menu, impossible d'effectuer une mise à jour depuis la recallbox, lorsque je quitte un jeux un son trés aigu se manifeste parfois.


  • Themer

    Bonjour,

    je remonte 2 problèmes sur ma vesion beta de recalbox:

    • impossible d'appairer ma manette sfc30 en bluetooth (avec l'erreur suivante : "Impossible d'associer la manette")
    • impossible de scrapper les images (avec l'erreur suivante : "Aucun système trouvé !")

    est ce que d'autres ont ces problèmes?
    merci



  • Erreur rencontré :

    Pendant le scrapping de mes roms un écran noir apparait puis plus rien ensuite obliger de repassé par l'interface WEB pour redémarré ES. ( https://file.ac/IrFaGZzOB8A/ )

    Second bug rencontré
    Une fois les infos d'un jeu éditée, les informations revienne comme ci elle n'avais pas été modifié. (j'ai tenté de supprimer le gamelist.xml mais rien y fait ce problème reviens toujours)

    3ieme bug rencontré : J'ai mis le Core CATSFC par default pour mes jeux SNES mais il ne me lance pas le bon core, il lance le core SNES9x 2015.



  • @chris256 said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    Bonjour à tous !

    Désolé de poster encore mais j'aimerais vraiment essayer quelque chose pour régler ce problème de son HDMI. J'ai installé recalbox version X84/64 dernière beta et, quel que soit ce que je choisis dans le menu audio comme sortie, je n'arrive pas à avoir de son sur HDMI (j'ai bien du son sous Windows via HDMI).
    Voici quelques lignes de log qui pourraient peut-être servir:

    • dans messages : input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input5
    • dans es_log : lvl0: VolumeControl::init() - Failed to find mixer elements!

    Je me souviens d'avoir lu quelque part qu'on peut en ligne de commande choisir sa sortie. Y-a-t'il une chance que ça aide ? Avez-vous un lien.

    PS : à moins que personne n'ait de son HDMI sur la version X86 de la dernière beta ?

    Merci beaucoup !!

    J'ai un peu progressé sur mon problème de son HDMI sur carte ATI. J'ai regardé ce lien. Après avoir choisi ma sortie HDMI dans le menu, je me suis connecté en ssh et j'ai lancé la commande alsamixer. Le son HDMI était bien sur mute. J'ai donc appuyé sur la touche m puis Esc pour sortir.

    Et j'ai bien le son mais... aussi bien dans ES que dans les jeux, le son fait des micro-coupures toutes les 2/3 secondes (pas très régulier). Une idée ?

    J'y suis presque, c'est frustrant ;-) Voici l'archive support si ça peut aider :
    https://file.ac/iM1z4wff8K8/

    PS : si je choisis la sortie Jack de la carte son qui est dans le PC, pas de coupures, c'est parfait. Par ailleurs, quand HDMI est sélectionné, le son est sur 0. Si je bouge le curseur, ça n'affecte pas le volume (et dans alsamixer, c'est soit mute, soit 00).

    Merci !!



  • @myst

    Pour controller BT

    ajoute le script suivant dans

    /etc/init.d/S99custom

    #!/bin/bash
    
    echo 1 > /sys/module/bluetooth/parameters/disable_ertm
    

    Mon controller Xbox s'appaire sans PB!


  • Themer

    @elecolive les controlleurs xbox ne sont pas bluetooth...



  • Hello.
    Since I'm new here I first of all have to say, thanks al lot for this wonderful piece of software :-)

    I installed this beta Version on my new rpi3b+ and so far, after reading this whole thread (well, most of it) i got most of my problems sorted out, most importantly, my 8bitdo sf30 pro is working now (had the problem that it did not work in retroarch, like mentioned above, fixed by mapping the l2/r2 buttons again).
    Overclocking seems to work too.
    So here are my unsolved problems:

    1. The biggest thing is, Retroachievements isn't working. I tried putting in my name/password in menu as well as in recalbox.conf.
      It says, when starting a game, that I'm logged in with my username, but then says that this game has no achievements.
      I tried it across several different systems (snes, nes, megadrive, etc.), with lots of different roms and romversions, but its the same with all of them. Is there something I'm missing? Or does it not work as of now?

    2. Next thing is, i can choose favorites, they then show up in the main system select screen, but after a restart, they are gone.

    3. I cannot access the emulators menu in n64 and neogeo. I can access it with hotkey+b in snes, megadrive, nes, pcengine, even psp. This seems rather important, since most n64 games i tried so far seem to need some tinkering with the settings.

    I don't know if these are related to the betaversion, since I havent used other version before.

    Best regards :-)



  • Je ne sais pas si c'est lié avec la beta (quoi que je n'avais pas ce problème avec la version stable) lorsque j'utilise le rewind il arrive fréquemment de ne peux plus pouvoir rembobiner. Un message m'indique "reached if rewind buffer"



  • @chris256 Je continue à avancer... Je viens de tester avec une autre carte graphique (Nvidia GTX 550). Toujours pas de son au départ en choisissant la sortie HDMI mais lorsque j'utilise l'instruction alsamixer et que j'enlève mute qui est activé au départ via la touche m là ça fonctionne, et sans coupure de son comme avec la carte ATI. Par contra la carte Nvidia a de bien moins bonnes performances que la ATI et comme mon objectif était de jouer à la n64, j'aimerais vraiment réussir à faire marcher la ATI. Si un développeur passe par là et peut m'aider ? À moins qu'il soit mieux de créer un nouveau topic dédié à ça ? (je me doute que la priorité est au raspberry mais je ne suis peut-être pas le seul dans ce cas sur X86).

    En tout cas, à ceux qui n'auraient pas de son en HDMI sur X86, tentez alsamixer.

    PS : en désespoir de cause j'ai essayé avec batocera mais j'ai exactement le même souci avec la carte ATI.



  • Hi all, hello dear devs :) ,

    I have just updated my image from 507-bump-bui (4ad393af) 36325817 rpi3 2018/11/12 18:53:18 to 507-bump-bui (361600e2) 38422234 rpi3 2018/11/29 21:24:06

    I have tried both on a rpi3 as well as rpi3b+

    In both cases, I have two bugs to report that didn't appear on the rpi3 with the stable version:

    • Unable to save games in favorite. Just the pharaoh game is there for some reason, but unable to save any other game.

    • I have saved a second SSID and passwords on the .conf file, but it doesn't connect.

    I have a few questions:

    • How can I help besides what's on the first post, i.e. use it normally until hitting a bug? I am not an OS developer, so I can mostly do testing. Unfortunately I don't have access to the stable version to use on my rpi3 as it's used for another project, so I'll be only on the rpi3b+ with the dev version.

    • The shown RAM memory is half of what it should be:

      # cat /proc/meminfo 
      MemTotal:         507292 kB
      

      is it because half the ram is used elsewhere? I don't recall if that was the case with the stable version...

    • I haven't seen the following question in the topic, which is surprising so I hope I won't get kicked-banned :p : Do you have an ETA for the stable version release?

    Thanks for all!

    edit: I see someone else reported 3 hours before me the issue with the list of favorite games not being saved upon restart.
    edit2: forgot to add that I used a PS4 pad with Bluetooth: works flawlessly!



  • @nihil-baxter

    concerning the n64 emulator menu, it was the same with the stable version. The only thing that worked was hotkey+start to quit.



  • @hyamanieu yeah, forgot to mention that exiting the game works, but thanks for info.

    so, is there another way to alter the n64 settings?
    read somewhere, that it is possible to change retroarch menu in game to some xmb, which should work then, but i have no clue...

    concerning the shown memory that s mentioned 2 posts above, mayby the rest is used for video ram?
    but cannot confirm what is shown in my recalbox, not at home atm.



  • Bonjours, j'ai en ma possession une manette 8bitdo n30 pro et je rencontre un problème(2 même), lorsque je configure les touches, le bouton A et B sont inverser, et lorsque je suit en jeu il met impossible de le quitter !
    Je suit sur la dernière version bêta?

    Edit même avec mes manettes xbox one élite et celle de la one x en filaire les boutons A et B sont inverser et impossible de quitter les jeux !



  • La c'est bon j'ai réussi enfin, sauf que la manette ne marche plus dans les jeux !!



  • I know this is not a bug report but could you add a swap A and B button option in the ES menu? I own many SNES layout pads (a Hori pokken pro pad, a PSP with FuSa Gamepad, a Wiimote and soon a Hori fighting commander for the SNES classic) so I would preffer to have A as accept



  • Hi,

    finally I found time to test (latest) Beta on my Pi3 B+, fresh install.
    Most things look to work fine, here feedback list of the ones that don't:

    • (Internal) WiFi works only sometimes. Really don't know why most time it doesn't connect, but sometimes it does.
      Maybe it's connected always, but after only long time when system rebooted - I have to further check out behavior. - While I'm writing this text, it suddenly connected again by itself ;) - And it seems as soon as it's connected, it won't lose connection anymore as long as system isn't rebooted.
    • When I enable "Security", Recalbox Manager is still dead. - Fortunately at least when disabling Security, it's working again. - At old Version it seemed to be dead forever afterwards ;)
    • 8Bitdo SF30 Pro Gamepad only worked after remapping as described already in this post. And with taking care L-R buttons are mapped as buttons instead of axis.
    • When searching bluetooth controllers, I sometimes have a strange view with many device details shown, instead of the compact list of devices. Anyway, already had this issue in latest stable version and when I scroll to the end, there is the compact view and connecting controllers work fine though. Have to mention that I saw this behavior on stable only with external bluetooth dongle, with beta, I have it with Pi3 B+ internal bluetooth.

    In my point of view there is not too much left to releasing a "stable" version for Pi3 B+ :)

    Thanks again for this great software!



  • @chris256 said in Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...):

    @chris256 Je continue à avancer... Je viens de tester avec une autre carte graphique (Nvidia GTX 550). Toujours pas de son au départ en choisissant la sortie HDMI mais lorsque j'utilise l'instruction alsamixer et que j'enlève mute qui est activé au départ via la touche m là ça fonctionne, et sans coupure de son comme avec la carte ATI. Par contra la carte Nvidia a de bien moins bonnes performances que la ATI et comme mon objectif était de jouer à la n64, j'aimerais vraiment réussir à faire marcher la ATI. Si un développeur passe par là et peut m'aider ? À moins qu'il soit mieux de créer un nouveau topic dédié à ça ? (je me doute que la priorité est au raspberry mais je ne suis peut-être pas le seul dans ce cas sur X86).

    En tout cas, à ceux qui n'auraient pas de son en HDMI sur X86, tentez alsamixer.

    PS : en désespoir de cause j'ai essayé avec batocera mais j'ai exactement le même souci avec la carte ATI.

    Enfin une solution à mon souci. Un ami m'a donné une nouvelle carte mère. Toujours le même souci de son avec la carte ATI. Par contre, cette nouvelle carte mère a une sortie optique. J'ai dû passer par alsamixer car j'avais une nouvelle fois mute sur la partie SP/DIF. Note aux développeurs : si c'est possible, peut-être faudrait-il tout mettre tout en unmute par défaut ?

    Mon problème de son réglé (enfin s'il y a une solution pour le problème Audio HDMI je suis bien sûr preneur), voici quelques retours de bugs :

    • s'il y a un favori dans un des systèmes, lorsque je rentre dedans avec ES, ES plante (je peux le relancer via le manager). Je précise que mes jeux sont sur réseau et que je suis en gamelist only. J'ai pas trop envie d'enlever les favoris car pour le moment, ces jeux sont partagés avec mon RPI qui est sur la version stable. Donc s'il y a une solution temporaire à ce problème de favoris, je prends.
    • pour la PlayStation, seul le core PCSX_REARMED fonctionne. Lorsque les cores MEDNAFEN_PSX_HW ou MEDNAFEN_PSX, je suis renvoyé à l'écran d'accueil. Je précise que les jeux sont en .iso. Le problème peut-il venir de là ?

    Sinon encore bravo pour tout le travail accompli !!

    PS : c'est mieux français ou anglais dans ce thread ? Je peux traduire si c'est utile.



  • How can I go back from the last update to the "full" beta image without complete re-writing the sd card (I'm on pi 3b+)?

    The not working scraper drives me nuts and I would like to use the version before, where the scraper was working without problems.



Want to support us ?

Join us on :

441
Online

39925
Users

16881
Topics

127074
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.