Probleme de config manette lors du boot



  • Salut tout le monde,

    J'ai un probleme depuis la version de Juin (et de Juillet aussi).
    Mon setup - Recalbox depuis version 3.7. Mis a jours stable. Jamais de problemes particuliers.

    A chaque reboot (depuis la version de Juin et Juillet) il me demande de refaire la config d'un joystick. J'en avais marre de faire ca donc je fais un coup de HOTKEY puis je me retrouve rapidement sour ES. Une fois la dessus je relance ES et tout marche... Bref c'est bidouille, ca prend du temps et surtout c'est pas normal... Les joysticks que j'utilise sont ceux que vous voyez dans les photos - ca marche depuis plusieurs annees sans problèmes.

    Je suis preneur de tout conseil que vous pourriez me donner. Pour moi ca ressemble a une regression depuis les précédentes version.

    Probleme lors du boot
    alt text

    avec les joysticks un coup de HOTKEY
    alt text

    puis bouton START pour se retrouver dans le menu d'ES
    alt text

    Je navigue dans les menus pour relancer ES (Via Update Game list)
    alt text

    et tout marche.
    alt text

    Les images en plus grande taille sont ici
    https://ibb.co/miQbdd
    https://ibb.co/iiwtPJ
    https://ibb.co/kDn6dd
    https://ibb.co/gPhiPJ
    https://ibb.co/h8SuWy

    Et mon archive de support
    https://file.ac/-XRJ6NOC8SA/



  • @acris - je voulais savoir si tu avais une idee pour ce probleme? Merci par avance ;-)


  • Moderator
    Team

    capture illisible
    carte sd corrompu sans doute
    si tu es dur stockage externe renomme ton dossier recalbox en recalbox.old.
    refais la config sur support externe et transdfert
    UNIQUEMENT les roms et bios.



  • Merci d'avoir regarde @acris. Les images plus grandes sont la dessus.

    Je pars sur une 100% fresh install... on va voir ce que ca donne vu que j'ai des plusieurs backup. La config de mes 2 joysticks du bartop semble ne pas aimer a priori... Il ne les garde pas en tete et ca merde. Pourtant rien de nouveau cote matos la dessus.

    @snwfrd38 said in Probleme de config manette lors du boot:

    Les images en plus grande taille sont ici
    https://ibb.co/miQbdd
    https://ibb.co/iiwtPJ
    https://ibb.co/kDn6dd
    https://ibb.co/gPhiPJ
    https://ibb.co/h8SuWy



  • he @acris.
    Je viens de faire une install sur une copie fresh SD et le probleme est le meme.

    Il semblerait que mon keyloggeur ne soit plus reconnu alors qu'il a toujours bien fonctionne. Les deux manetters sont connecte sur ce keyloggeur. En fait dans la version actuelle je ne peux configurer que une des deux manettes dans ES et il ne reconnait pas les hotkey / start dans les jeux (alors que sous ES oui). A mon avis il semblerait que ce soit un probleme d'un effet de bord depuis la version de Juin.

    dans ES je pouvais voir le keyloggueur comme XArcade comme indique dans l'image
    https://ibb.co/kDn6dd

    et dans le recalbox.conf le XArcade est bien "enabled=1"

    Aujourd'hui il n'apparait plus du tout et est vu simplement comme un clavier.
    Je viens de regarder dans le fichier

    pour info sur l'archive support on le trouve :
    Bus 001 Device 004: ID 2341:8036
    Device Descriptor:
    bLength 18
    bDescriptorType 1
    bcdUSB 2.00
    bDeviceClass 0
    bDeviceSubClass 0
    bDeviceProtocol 0
    bMaxPacketSize0 64
    idVendor 0x2341
    idProduct 0x8036
    bcdDevice 1.00
    iManufacturer 1 Arduino LLC
    iProduct 2 ArcadeForge Key Strike



  • @acris - c'est un bug dans le script "S26*" et la fonction de detection de l'XArcade.
    En le forcant a la main ca marche....


  • Moderator
    Team

    @Substring a un xarcade
    il controlera à son retour de vacances dans 3 semaines


  • Moderator
    Team

    @snwfrd38 tu as du oublier de créer le fichier utile pour que xarcade2jstick prenne en compte ton matos



  • @Substring oui je l'ai recree hier et j'ai vu que ca fonctionnait lors du boot mais pas toujours... La config est toujours la c'est la detection qui semble etre hesitante. A mon avis qq chose a changer dans la detection car mon materiel n'a pas bouge. Je continue de regarder dans les differents scripts. A+ (et bonne vacance!)


  • Moderator
    Team

    @snwfrd38 merci ^^

    Le seul truc qui a changé, c'est qu'on a mis la détection des sticks en // des autres taches au boot au lieu de les mettre en sequentiel. Ça dépend aussi de la durée pour détecter ta carte (les xarcade sont une plaie pour ça ...)



  • @substring

    oui j'ai vu la detection en // (script S26qq chose dans init.d). Je vais le modifier pour le mettre en sequentiel ce soir.



  • @Substring @OyyoDams
    Je confirme la modification de S26recalboxsystem est ce qui genere chez moi la perte de la config lors des reboot.
    J'ai modifie a la main mon script S26 pour mettre la version avant la version et c'est beaucoup plus stable - la config du XArcade ne se pert plus.

    https://gitlab.com/recalbox/recalbox/commit/fbcc876fd01181ce629ebed23f0830b2aa83174a

    Ma sequence est la suivante avec le wait a la fin. Ca marche beaucoup mieux chez moi ;-)

    rb_timezone&          # 0.4
    rb_hostname&          # 0.4
    ( sleep 8 ; rb_xarcade2jstick ) &    # 0.1
    wait

  • Moderator
    Moderator
    Team

    @snwfrd38 bien vu. Va falloir ajouter une option pour ne charger ce driver que si nécessaire.


Log in to reply
 

Want to support us ?

Join us on :

313
Online

27481
Users

14136
Topics

107288
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.