Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Pi3 Won't Pick Up 18.02.09 Update

  • Not that I am aware of... And I don't think anything changed router-wise recently... Never had this issue before. What can I ping to test if it's being blocked?

  • @miso117 try 0.pool.ntp.org <hich is configured in Recalbox.

    Are you using a VPN somehow ?

  • No sir, no VPN.

    ping 0.pool.ntp.org

    PING 0.pool.ntp.org ( 56 data bytes
    64 bytes from seq=0 ttl=44 time=107.194 ms
    64 bytes from seq=1 ttl=44 time=111.607 ms
    64 bytes from seq=2 ttl=44 time=115.827 ms
    64 bytes from seq=3 ttl=44 time=112.106 ms
    64 bytes from seq=4 ttl=44 time=107.803 ms
    64 bytes from seq=5 ttl=44 time=106.538 ms
    64 bytes from seq=6 ttl=44 time=109.017 ms
    64 bytes from seq=7 ttl=44 time=117.462 ms
    64 bytes from seq=8 ttl=44 time=106.942 ms
    64 bytes from seq=9 ttl=44 time=110.637 ms
    64 bytes from seq=10 ttl=44 time=109.292 ms
    64 bytes from seq=11 ttl=44 time=121.090 ms
    64 bytes from seq=12 ttl=44 time=109.837 ms

    --- 0.pool.ntp.org ping statistics ---
    14 packets transmitted, 13 packets received, 7% packet loss
    round-trip min/avg/max = 106.538/111.180/121.090 ms

    looks like it is hitting it just fine.

  • @miso117 do you have a real recalbox and not some internet lousy image ?

  • I put the image directly on the SD card myself when 17.12.02 was released from the Recalbox site.

  • Staff

    @miso117 can you connect with putty, and write:
    bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgrade

    What's the result ?

  • looks like its hanging @

    login as: root
    root@'s password:

    bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgrade

    • COMMAND=canupgrade
    • [[ -z canupgrade ]]
    • BINDIR=/recalbox/scripts/upgrade/
    • SYSTEMSETTINGS='python /usr/lib/python2.7/site-packages/configgen/settings/rec alboxSettings.pyc'
    • RECALBOX_SYSTEM_DIR=/recalbox/share/system
      ++ cat /recalbox/recalbox.version
    • INSTALLED_VERSION=17.12.02
      ++ cat /recalbox/recalbox.arch
    • ARCH=rpi3
      ++ python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.p yc -command load -key updates.type
    • UPGRADETYPE=stable
    • SERVICE_URL=https://recaleur-archive-prod.recalbox.com:9443
      ++ /recalbox/scripts/upgrade//../system/uuid.sh --uuid-file /recalbox/share/syst em/uuid
    • UUID=06ac36bf-6776-4102-bb73-773e11328db4
    • [[ stable == \b\e\t\a ]]
    • [[ stable == \u\n\s\t\a\b\l\e ]]
    • '[' canupgrade == canupgrade ']'
    • [[ stable == \s\t\a\b\l\e ]]
    • /recalbox/scripts/upgrade//recalbox-canupgrade.sh --from-version 17.12.02 --se rvice-url https://recaleur-archive-prod.recalbox.com:9443 --arch rpi3 --uuid 06a c36bf-6776-4102-bb73-773e11328db4
      % Total % Received % Xferd Average Speed

  • Putty sits there at % Total % Received % Xferd Average Speed - No blinking cursor, doesn't look like its doing anything...

    I have my ROMS folder pulled, I can just do a fresh image. No biggie... I can do that and let you know if I still see the weird date thing after.

    Let me know if you want to try to keep plugging at it or start fresh. I'm OK either way.


  • @miso117 you do have a problem somewhere ... As if port 9443 is locked. Let's force it another way :
    bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh upgrade

    Is it your first recalbox installation ?

  • It seems to have hung in the same place... I am going to reinstall from scratch. I have been using Recalbox for a couple years now, I have a RPI2 and for Christmas got a RPI3. I can't remember if this was the first load or if it was a load and upgrade on the newest PI, but either way, something is jacked up.

    I backed up my ROMs and am going to do a fresh install. If I still see the date issue after I will let you know.

    I really appreciate the help and info, you all rule!

  • Did a fresh etch from the newest image and once Recalbox was up I SSH'd to it and #date gave me the correct time.

    It had to be something with the last build, or my SD card... Not sure which, but it is resolved now. Thanks everyone. I so appreciate this community!

  • Hi all,

    I have a pretty same issue. I can't update to 18.02.09. The ping works fine but when i run the command bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgradeI have the following error at the end : 0curl: (7) Failed to connect to recaleur-archive-prod.recalbox.com port 9443: Connection refused
    Any idea ?

    Thank you

  • I'm having a similar issue after I tried a beta version a while ago: https://forum.recalbox.com/topic/12240/testers-wanted-network-share-over-wifi

    bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh upgrade

    • COMMAND=upgrade
    • [[ -z upgrade ]]
    • BINDIR=/recalbox/scripts/upgrade/
    • SYSTEMSETTINGS='python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.pyc'
    • RECALBOX_SYSTEM_DIR=/recalbox/share/system
      ++ cat /recalbox/recalbox.version
    • INSTALLED_VERSION='292-wifi-aft (2ce937e1) 15982104 rpi3 2018/01/10 08:14:58'
      ++ cat /recalbox/recalbox.arch
    • ARCH=rpi3
      ++ python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.pyc -command load -key updates.type
    • UPGRADETYPE=stable
    • SERVICE_URL=https://recaleur-archive-prod.recalbox.com:9443
      ++ /recalbox/scripts/upgrade//../system/uuid.sh --uuid-file /recalbox/share/system/uuid
    • UUID=c7553d05-d17d-4683-baab-c5c9f26091b3
    • [[ stable == \b\e\t\a ]]
    • [[ stable == \u\n\s\t\a\b\l\e ]]
    • '[' upgrade == canupgrade ']'
    • '[' upgrade == upgrade ']'
    • [[ stable == \s\t\a\b\l\e ]]
      ++ /recalbox/scripts/upgrade//recalbox-canupgrade.sh --from-version '292-wifi-aft (2ce937e1) 15982104 rpi3 2018/01/10 08:14:58' --service-url https://recaleur-archive-prod.recalbox.com:9443 --arch rpi3 --uuid c7553d05-d17d-4683-baab-c5c9f26091b3
      % Total % Received % Xferd Average Speed Time Time Time Current
      Dload Upload Total Spent Left Speed
      0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
      curl: (22) The requested URL returned error: 400 Bad request
    • [[ 22 != \0 ]]
    • exit 1

  • Staff

    @shira Try the following:

    Edit /recalbox/recalbox.version and replace the content with 18.02.09

  • @oyyodams said in Pi3 Won't Pick Up 18.02.09 Update:


    Tried that and it started upgrading, restarted, got the msg about system being upgraded but it got stuck at 36% forever, restarted.. now it won't boot. I will do a fresh install I guess.

Want to support us ?





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.