Retroarch



  • Hello, j'ai donc fait un accès direct via emulstation, (Au fait c'est pas F4, mais CTRL F4 si on veut qu'il se passe quelque chose, après ALT F2, pas de soucis) Je tape ce qu'il faut et termine avec DMT. Là, miracle, ça fonctionne, et tv service me sort une douzaines de modes possibles. Il me conseil le mode 35 : 1280X1024 @ 60 Hz 5:4, clock : 108 Mhz progressive J'ai tout un tas de choix en 4/3 1024 X 768 .... Je voulais tester le mode 16 afin d'envoi un 4/3 1024 X 768. Donc à la fin de la ligne tvservice j'ai tapé la commande que tu m'as indiqué et l'ensemble ressemble à ça : (global.videomode=DMT 16 HDMI) mais ça me met command not found. On doit pas être loin, je reviens ce soir si tu as d'autres conseils. Encore merci pour ta patience.


  • Moderator
    Team

    En effet on est pas loin =) Cette ligne, global.videomode=DMT 16 HDMI tu dois la documenter dans ton recalbox.conf. Etant donné que tu es déjà en mode console, on va continuer ainsi ^^ Cette commande va te permettre d'éditer ton fichier de config via l'éditeur texte nano : nano /recalbox/share/system/recalbox.conf Là tu modifies la ligne global.videomode= avec tes paramètres, puis tu fais ctrl + x pour quitter suivi de y pour sauvegarder. Tu te retrouves de nouveau dans ta console. Tu tapes alors un reboot et tu regardes ce qui se passe. Tu pourra également tester le mode 35 : 1280X1024 @ 60 Hz 5:4, clock : 108 Mhz progressive, je connais d'autres users qui l'utilisent sans soucis avec ton type d'écran.



  • Yes je confirme que le mode 1280x1024 @60 marche impec sur un 19 pouces dont c'est la résolution native. Le piqué d'image est même bien meilleur que dans toutes les résos inférieures (1024*768, 800x600 ou 640x480) qui semblent légèrement plus floues. Ce qui est somme toute normal dans la mesure où le mode 1280x1024 est le seul à respecter le ratio image 5/4 natif du moniteur et n'oblige pas l'électronique à "rescaler" le signal en entrée ce qui n'est pas le cas des autres résos 1024x768, 800x600 et 640x480 qui ont un ratio 4/3 :)



  • Salut Rockaddicted, je dois dire que tes Tutos sont aux petits oignons. J'ai enfin ce que je voulais sur mon écran. J'ai fais un test avec le mode 35 ainsi que le 16. Perso je ne vois pas la différence. J'ai bien mon image sur tout l'écran avec les 2 versions :) C'est vrai que le ratio d'un écran 19 pouces, c'est 5/4 et pas 4/3. Peut être à privilégier, surtout que la fréquence est un peu plus balaise, à voir à l'usage. Maintenant il y a plus qu'à jouer, et je vais surtout m'atteler à la construction de mon Bartop. Juste une dernière chose, concernant la MAJ, quelle est la différence dans les shaders entre "Scanlines" et "Rétro", je ne vois pas pour le moment, mais j'ai juste fait des essais sur super nintendo. Encore une fois, merci infiniment. Bonne continuation à toute l'équipe.


  • Moderator
    Team

    haha bonne nouvelle =) Concernant les shaders on a opté pour du sobre. le set "retro" applique une correction gamma + un très léger effet "blur" + des scanlines, contrairement au set "scanline" qui lui n'applique que les scanlines. Si tu switch ingames avec la commande hotkey+R2/L2, tu verra les différences. Ça reste subtile, et c'est voulu. On en a aussi profité pour proposer d'autres presets, s'éloignant du rendu original, avec lissage etc.... qui sont hors set, mais accessibles via les commandes spéciales, et assignables à la mano via le fichier de config de la recalbox recalbox.conf. N'hésites pas si tu as de nouveau des questions, ou des soucis pour trouver des romset (arcade notamment), forum ou IRC (on squatte pas mal dessus)



  • Ah ba, si en plus il y a un service après vente qui déchire, je passerai sur IRC. Perso, je ne suis pas pour le lissage des pixels, après ça dépend de la taille de ton écran. Maintenant, si vous voulez encore accentuer un peu le délire Oldschool, il pourrait très bien y avoir un scanline un poil plus violent avec une bonne accentuation des couleurs / lumière, je dis ça, c'est plus pour le mame, Néogéo .... de l'arcade. Histoire qu'on voit vraiment bien le pixel. Bref, je chipotte, mais c'est super ce que vous avez fait, et j'en ai testé ... Au plaisir



  • Bonjour, Je me permets de venir ici, j'ai commencé avec Recalbox il y a 2 jours. C'est vraiment top. Tout fonctionne bien en NES, mais bon c'est pour mes enfants quoi... Pour ma part je suis plus intéressé par les jeux  d'arcade, que je connais bien, j'ai joué des années sur mon PC avec Mame et une flopée de ROMS tout fonctionnait au poil. Par contre je rencontre des difficultés pour jouer à ces jeux sur mon RPI. Il n'y a que quelques rares ROMS qui passent. (Alors que j'ai tout redownloadé pour l'occasion) X-Men vs Street Fighter par exemple, passe sur FBA et non sur MAME.  Je pensais à un problème de bios au départ, ce qui fait que j'ai mis tous les BIOS dans le même directory que les ROMS MAME : sans succès. dans le directory BIOS : pareil. Ce qui me fait venir ici, c'est que je pense que c'est un problème de résolution, car quand je lance X-Men vs Street Fighter sous FBA, la ROM se lance et ma TV m'affiche en info que je passe en 720p.   Alors que tous les autres jeux, je pense, essayent de se lancer en 1080p. Pour les ROMS qui ne fonctionnent pas, le symptôme c'est : Je choisis la ROM, j'appuies pour la lancer, écran noir pendant 3 à 5 secondes et je reviens à la liste des ROMS...   Merci d'avance pour votre aide.     EDIT: J'ai oublié de dire aussi, que quelques ROMS se lancent et j'arrive sur une interface retroarch qui me déroute quelque peu. Même si j'ai compris le principe: il faut charger manuellement un Core puis un fichier ROM mais je ne comprends pas la manip, surtout où trouver un fichier core....


  • Moderator
    Team

    Hello à mon avis ton soucis vient plutot des romsets utilisé. Chaque émulateur doit utiliser un romset mame d'une version bien précise. Tu peux te référer à ce post pour plus d'informations : https://github.com/digitalLumberjack/recalbox-os/wiki/Ajoutez-des-jeux-d'arcade-(FR) Si tu ne trouves pas les romsets, sache que l'on pourra t'apporter de l'aide sur le IRC. Il nous est impossible de poster des liens pointant vers du contenu sous copyright sur le forum ;)



  • OK, merci à toi, je vais regarder ça !



  • Bonsoir à tous, J'ai une très bonne nouvelle. J'ai changé mon branchement sur mon écran, en conservant les paramètres ci-dessus. J'ai remis l'adaptateur qui permet de convertir du HDMI vers le VGA. J'ai zappé le HDMI vers DVI (câble sans convertisseur) Et là, miracle, l'image est parfaite. Le truc qui fait que c'est encore plus parfait, c'est que l'adaptateur comporte une sortie jack. On règle, le problème original du son qui sort du jack du PI. Le son, est parfait, et le 2.1 envoie parfaitement. Je vais donc me bricoler, une deuxième carte SD, celle ci en gardant les paramètres originaux, pour voir, ce que le Stream de Steam à dans le ventre. Encore merci à tous.



  • Bonjour, Ma bartop avance bien de mon coté mais j'ai un souci de centrage d'image ! Et j'ai beau avoir utilisé plein de ressource de votre forum je n'arrive a rien ! Je pensais avoir trouvé avec ce tuto mais au final non .... J'ai cherché au niveau de Retroarch et j'ai trouvé comment centré l'image mais au final en ressortant du logiciel  ca ne sauvegarde pas le modifications. J'ai l'impression qu'il ne charge pas quelque chose au démarrage ? Merci de votre aide !



  • Au final j'ai trouvé ma réponse ! Je détaillerais plus tard !


  • Moderator
    Team

    Le save on exit qui n'était pas activé je présume ? N'hésite pas en effet à détailler ce que tu as fait afin que cela puisse plus facilement aider les prochains utilisateurs qui rencontreront la même problématique que toi :).   Merci par avance :)



  • Au final en utilisant la méthode indiqué ci dessus et en modifiant la résolution avec : <span style="color: #737c85; font-family: 'Open Sans', sans-serif; font-size: 12px; line-height: 26px; background-color: #fbfbfb;"> </span><code style="box-sizing: border-box; font-family: Inconsolata, Consolas, Monaco, 'Lucida Console', monospace; font-size: 12px; display: inline-block; border: 1px solid #dddddd; padding: 0px 5px; max-width: 95%; vertical-align: middle; margin-top: -3px; color: #737c85; line-height: 26px; background-color: #f9f9f9;">global.videomode=DMT 33 HDMI Ca ne marchait pas il a fallu que j'essaie d'autres résolutions pour trouver une qui fonctionnait. J'avais pourtant bien utiliser la commande <span style="color: #737c85; font-family: Inconsolata, Consolas, Monaco, 'Lucida Console', monospace; font-size: 12px; line-height: 26px; background-color: #f9f9f9;">tvservice -m DMT</span> Pour connaitre la liste de mes résolutions possibles....


Log in to reply
 

Want to support us ?

Join us on :

314
Online

29667
Users

14863
Topics

111976
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.