Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[Wip] Projet gameboy zero en cours - Bartop terminé



  • @tibreizh de ce que j'ai cru comprendre tu utilises ta carte sd sur ton pi 3 et ton pi zéro... Les versions recalbox pour pi3 et pi zéro ne sont pas les mêmes, c'est peut être la qu'il est ton problème. Si j'me gourre fais pas attention à ma remarque 😉



  • @tillandsie said in [Wip] Projet gameboy zero en cours - Bartop terminé:

    @tibreizh de ce que j'ai cru comprendre tu utilises ta carte sd sur ton pi 3 et ton pi zéro... Les versions recalbox pour pi3 et pi zéro ne sont pas les mêmes, c'est peut être la qu'il est ton problème. Si j'me gourre fais pas attention à ma remarque 😉

    Ah... ouai ... d'accord^^.

    Alors ne cherchons pas plus loin, tu as trouvé le problème. 🙂

    je trouvais incroyable que aucun RPZ ne marche.

    Je vas aller télécharger la bonne version, ça fonctionnera mieux.

    Merci beaucoup @tillandsie, je me doutais que ce n'étais pas grand chose, mais je ne m'en sortais pas.
    je zieutais déjà comment rentrer le RP3 dans le game boy 😛

    Edit:

    En fait il semblerait ce soit la même version pour RP3 et RPZw donc retour à la case départ, pourquoi la même carte SD fonctionne sur le RP3 et pas sur les RPZ

    en tout cas merci du coup de main 😉



  • @tibreizh demande à @Substring mais je suis sur qu'il y a une différence.
    Elle se fait peut être au moment de l'installation sur le pi zéro. En tout cas, les sd de mes pi zéro ne fonctionnent pas sur le pi 3 et celles des pi 3 ne fonctionnent pas sur mes pi zéro 😉



  • @tibreizh kamoulox, la version pi0 c'est la même que pi1



  • @substring said in [Wip] Projet gameboy zero en cours - Bartop terminé:

    @tibreizh kamoulox, la version pi0 c'est la même que pi1

    Merci @tikiandskull et @substring.

    C est donc une version Différente, donc mes cartes SD paramétrées sur RP3 ne risquent pas de fonctionner...
    Par contre je ne trouve pas la version rp1^^

    Un lien peut être ?

    Merci du coup de main 😉


  • Developer
    Global moderator
    Team



  • @oyyodams said in [Wip] Projet gameboy zero en cours - Bartop terminé:

    @tibreizh https://archive.recalbox.com/

    Top, merci 😉
    Je test tout ça ce soir et je vous fais un retour.

    Un grand merci à vous 3 😊



  • Ca fonctionne !!!
    La version est la bonne, je vais pouvoir passer à la suite.

    -Mission audio:
    Soudage du hub USB, carte son, ampli, prise jack et haut parleur

    je voulais également charger des roms sur la carte SD, mais je n'arrive plus à me connecter que par le recalbox manager.

    Impossible de me connecter via l'explorateur windows.
    Pourtant cela fonctionnait il y a peu de temps sur mon ordi et c'est ainsi que je procédais.

    Quand je tape //ipdemonpizero dans la commande de l'explorateur windows, je bascule direct sur internet et recalbox manager.
    0_1518459207579_explorateur reseau windows.jpeg

    et quand j’exécute cmd ping ipdemonpizero , il est bien reconnu.
    0_1518458559729_ping.jpeg

    une idée sur ce qui bloque ?

    des dizaines de sujets existent sur le sujet, mais pas de solution trouvé.

    prochaines photos, le cablage audio 😉

    Et encore merci pour l'aide sur la version recalbox pi0 😉



  • Salut à tous,

    Mon projet game boy progresse doucement mais surement.
    je n'arrive toujours pas à me connecter à mon navigateur réseau windows, mais j'utilise winSCP, donc problème by passé ^^

    Mes 2 écrans (gear best et ecran de recul) fonctionnent.
    Le gear best est largement plus net que l'écran de recul.
    ecran gear best à gauche, ecran radar de recul (amzon ou ebay) à droite
    0_1518868796658_20180217_125408 (Large).jpg

    Le gear best
    0_1518868836416_20180217_125146 (Large).jpg

    ecran recul
    0_1518868854952_20180217_125155 (Large).jpg

    Et pour le prix je le recommande. environ 15€ fdp compris.
    il n'y a pas de possibilité de régler la luminosité ou le contraste sur le gear best, mais sa qualité d'image le place largement devant ses concurrents low cost pour projet GBZ cheap 🙂

    la quasi totalité des composants etant arrivé, j'ai pu les placer dans la coque afin d'optimiser la place de chacun.
    1_1518867710747_20180215_142756 (Large).jpg 0_1518867710396_20180214_184334 (Large).jpg

    j'ai raccordé le hub usb.
    j'y ai placé un port USB avec lequel je branche une manette pour pouvoir naviguer dans le menu de recal box: fct OK
    Et j'y ai raccordé ma carte son USB: là pas OK^^
    1_1518868999139_20180217_114653 (Large).jpg 0_1518868999138_20180217_114642 (Large).jpg

    L R et GRD de la carte son vers l'ampli sont connecté, car je n'arrive pas à avoir le moindre son, et je cherche la panne^^
    j'avais d'abord cabé comme ceci, incluant le jack headphone et le potentiomètre.
    0_1518872717292_28117484_10215041537409090_1657237804_n.png

    Mais n'ayant rien comme son, j'ai oublié le jack et potentiomètre pour brancher un HP 1w en direct, et toujours rien...
    0_1518872784176_28124564_10215041550529418_2008761115_o (1) (Large).jpg

    ma carte son est bien alimenté en 5v et les données par V- et v+ du port USB, elle clignote rouge, ce qui est bon signe
    l'ampli PAM 8304 adafruit est bien alimenté en 5v par le port VCC
    ground branché, et sortie L et R de la carte son branchés sur Audio in- et audio in+ de l'ampli.
    J'ai branché un haut parleur 1w en sortie + et - de l'ampli, mais rien, pas un gresillement. je n'ai aucune tension sur e port + et - en sortie de l'ampli.

    Et je suis bloqué, car j'aimerais avoir le son qui fonctionne avant de souder la carte controleur au gpio du RP.

    j'attend un ampli avec potentiomètre intégré de ce type pour pouvoir faire un autre essai.

    Et charger la carte son également pour test si c'es t elle qui à un soucis.

    Si vous voyez un problème dans e branchement, ou si vous avez utilisé un ampli de ce type, laissez un com 😉

    bon week end.



  • voici le shema de branchement que j'ai suivi.
    Pensez vous que ce soit correct ?

    0_1518898234972_ampligbz.jpeg

    et bizarrement dans le menu son de ES, lorsque je met le volume à 100% et que je fais OK, en retournant dans le menu il est à 0%
    la sortie son se fait bien en usb.
    0_1518899664425_20180216_212816 (Large).jpg
    0_1518899679277_20180216_194026 (Large).jpg



  • Sur le a+ l'audio droit ou gauche, sur le a- le ground de ta sortie audio, sur le Vin le 5v et à côté le ground, de l'autre côté sur ton schéma le fil rouge et le noir sont inversés.



  • @tikiandskull merci de passer par là 😉

    0_1518909172864_ampligbz1.jpeg

    comme ceci ?

    En fait, comme c'est un ampli mono, il n'y a qu'un cable audio a brancher je suppose ?
    je suis un plan depuis le debut, et je suis sûr qu'il m'embrouille ^^

    l'image de l'ampli est inversée, le D+ et D- de l'usb sont à l'envers^^, je ne sais pas ce que tu en penses ?

    0_1518909807793_1.png

    j'ai eu ce plan par un vendeur ebay, mais pense qu'il ne vaut pas grand chose...

    Je test ton conseil

    ++



  • j'ai refait le cablage.
    0_1518911931543_20180217_004149 (Large).jpg

    toujours pas de son.
    la carte son ne clignote plus rouge mais reste allumée en continu.
    je peux changer le volume dans ES et il reste en mémoire.

    0_1518912026590_20180217_004854 (Large).jpg

    j'essayerais en branchant le cable audio R à la place du L demain.

    Bonne nuit;



  • @tikiandskull

    j'ai branché le R sur A+ et le ground de la carte video sur A-
    le 5 v sur VCC et le GrD sur le ground de mon PDB
    la led de la carte video clignote rouge.
    j'ai réglé les option son ES: sortie : Auto (usb fonctionne aussi)

    Et j'ai du son !!!

    merci du coup de main.

    reste a ajouter le potentiomètre et la prise jack.

    A plus tard



  • @tibreizh pour la prise jack tu peux te référer à ça link text
    Et pour le potentiomètre à ça link text



  • @tikiandskull , merci pour les liens.

    Sur cette première version, Je n' ai pas mis de potentiomètre et prise jack , juste un switch on off pour couper le son et un accès à la vis de réglage de l ampli.
    Disons que c est mon modèle prototype, et comme je veux l offrir à un pote la semaine prochaine et que je n' ai plus de temps dispo, elle en restera la pour le moment.
    Je lui ferais des modifs plus tard.
    0_1519292560943_20180220_235123-1280x960.jpg
    0_1519292576071_20180220_235051-960x1280.jpg
    0_1519292599697_20180220_234931-960x1280.jpg
    0_1519292613319_20180220_234737-1280x1706.jpg

    Sur le prochain GBZ, il y aura jack et potentiomètre de volume. 😉

    Mon 1er game boy est maintenant terminé, et fonctionne bien au niveau vidéo et audio.

    Par contre au niveau joystick directionnel, les diagonales ne sont pas exceptionnelle, et sortir un "ha do ken" sur street fighter 2 est compliqué.

    Aussi j ai une question:
    Peut on brancher directement sur les port GPIO un stick analogique PSP 1000, ou doit on.asser par une carte contrôleur type teensy.

    Je trouve des discussions sur le sujet, mais souvent pour rétro pie.

    Avez vous utiliser des stick analogiques pour fabriquer une game boy zéro?
    Comment les avez vous connectés, configurés ?

    Hâte de me lancer dans mon GBZ v2.0 😉

    ++



  • @tibreizh sur la mienne je me suis contenté des contrôles classiques... mais je pense que pour des contrôles analogiques il faut passer par une carte teensy ou arduino micro.
    et je pense que pour un montage avec un pi zéro c'est pas vraiment utile... ou alors il faut faire une Gameboy avec un pi3 pour avoir des jeux sur lesquelles ces contrôles seront utilisable et la ça devient plus compliqué pour l'intégration du matériel.


  • Banned

    @tikiandskull le pi3 risque de poser problème niveau batterie surtout non ?



  • @voljega ouais aussi! 🙂 ça reste faisable mais le temps de jeu doit être assez court.



  • @tikiandskull , je trouvais étrange que mes diagonales soient si mauvaises avec la croix directionnelle.
    Seulement G+H et G+B
    Le reste des directions marchant proprement.
    J ai alors changé la croix directionnelle et le tapis silicone des contact.
    Et ça marche au poil !!!

    Certainement des éléments défectueux.
    Je suis soulagé.

    Et concernant le stick analogique, il est sur qu il commence à devenir intéressant sur des jeux tournant sous PS1 N64 et le pi0 est au bout sa vie^^

    Je n' ai pas encore testé de jeu N64, mais si Mario 64 arrive à tourner sous pi0, le stick commencera à devenir intéressant
    Même avec des jeux comme Doom 64 ou 007

    Par contre sur la prochaine, je met au moins L2 et R2 en plus.

    Bon weekend

    ++



Want to support us ?

269
Online

77.3k
Users

19.4k
Topics

144.1k
Posts