Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problem with moonlight

  • @substring if i put the IP from recalbox into my Chrome Browser have access to All the Things i need

    I dont See the Box in the Windows Explorer / Network view where i Can See the Fritz Box

    The Ping Thing is Just Ping IP into the Controll Pannel (f4)? I will try

  • @gimpi just SSH to it otherwise

  • @substring ok if i try to stream via Smartphone and i add the IP from my PC they said unable to connect make Sure the Requiem Ports Are allowed through Firewall

  • @gimpi so that's a GFE configuration problem. Have you logged in an account in GFE ?

  • @substring yes im logged in an gfe Account

  • @gimpi said in Problem with moonlight:

    @substring yes im logged in an gfe Account

    OK i Think im on the good way if i deaktivate the Windows Firewall i have stream access with my Smartphone Cant try it with the Pi now so i have to allow GFE to communicate through the firewall

  • @gimpi looks promising

  • @substring

    ok with firewall off it works to pair and i can stream steam ... but since the update 18.03.16 my controller doesnt work .. my wireless Keyboard works well in the Straming menu but the Bluetooth and even the USB Gamepad would not work

  • @gimpi i spent some time on the moonlight code ... its way of identifying pads is self made instead of using SDL2 helpers. The drawback is that if SDL2 changes its algorithm, we're fucked once again.

    I'll see what I can do in the future.

    Meanwhile there is a hack i've explained here

  • Hi!
    I've got a problem with Moonlight that I can't understand.
    I must say that I have a low level of computering, so maybe I did something wrong. Before anything, also sorry for my english.

    First of all, I downloaded Geforce Experience in 3.11 version so Recalbox would be able to connect to it and I added some games.
    I connected to Recalbox through WinSCP with SCP protocol. I did what the GitHub says typing:
    /recalbox/scripts/moonlight/Moonlight.sh find
    After that, I typed:
    /recalbox/scripts/moonlight/Moonlight.sh pair
    Once I did this, something unexpected happened. A little window of Nvidia Shield oppened asking for a ping so I could connect. I looked into the GitHub and I wondered if the ping should have appeared after what I typed. At least that was what GitHub seemed to be saying. As I had no ping to type, I pushed the "Connect" button anyway and, to my surprise, the ping appeared after that in the WinSCP and a message saying that my device was already paired.
    Then, I typed this:
    /recalbox/scripts/moonlight/Moonlight.sh init
    It said YOLO MODE, you know, but then appeared the text:
    Adding and scraping . . .
    And nothing more... Everything stopped here. I reseted the Raspberry, I repeated this process, I tried to connect through the new Moonlight option I had in Emulestation... But nothing. No game added, no scraping, no connection possible.

    I tried Moonlight in my phone just to check and everything worked, but not in Recalbox.

    What could I be doing wrong?

    Thank you very much!

  • @cheemix run the script with the clean parameter, and start again. You're supposed to type the pincode on your GFE host to allow pairing. If this step failed, you cab't go on

  • @substring Sorry, what do you mean by "clean parameter"?
    This is what happens to me. This appears at the same time:
    If I do nothing, awindow appears saying that WinSCP is going to close. I can ask it not to do so, but then nothing happens neither.
    If i push "Connect", it acts like everything is OK but the ping appears later.
    If I push "Cancel", the ping appears, but the NVidia window closes, so I have nowhere to put the ping...

  • @cheemix The weird thing is that, as you say, it says all the time "Failed to pair", but it doesn't tell me the ping before saying that. It gives me the ping after. And to open the Nvidia window I have to put the script again, but then the ping is not the one it told me before, so it fails again.

  • @cheemix It is like this all the time:

    /recalbox/share/system$ /recalbox/scripts/moonlight/Moonlight.sh pair
    () /recalbox/share/system/configs/moonlight/moonlight.conf | /recalbox/share/system/configs/moonlight/keydir
    Failed to pair to server: Streaming session has failed due to a game management error.
    Searching for server...
    Connect to XXXXXX...
    Generating certificate...done
    Please enter the following PIN on the target PC: 0663
    YOLO MODE !!!
    /recalbox/share/system$ /recalbox/scripts/moonlight/Moonlight.sh pair
    () /recalbox/share/system/configs/moonlight/moonlight.conf | /recalbox/share/system/configs/moonlight/keydir
    Failed to pair to server: Streaming session has failed due to a game management error.
    Searching for server...
    Connect to XXXXXX...
    Generating certificate...done
    Please enter the following PIN on the target PC: 3997
    YOLO MODE !!!

  • @cheemix don't run through winscp but through putty please

    I don't u derstand what you mean with ping, we only talk about a pin code you're given and that you have to input in that GFE box, then press connect

    For the clean parameter : replace pair or init by clean in the commandline

  • @substring Sorry, I said ping bt I meant pin. I'm going to try what you said

  • @substring Done! Thank you very much! The problem was using WinSCP instead of PUTTY... Sorry.

    Now the problem is that my PS3 controller doesn't work. It seems you have talked about that before, so I'm going to read it

  • @substring Sorry I'm such a noob! XD I read some conversations about pairing controllers and the truth is I still don't understand very much... I would like to use my original bluetooth Sony PS3 controller in Moonlight as I do with the emulators in Recalbox, but I'm not very sure this will be easy. Is there alredy a way that doesn't imply mapping manually or are you still working on that? The only thing I can do by now is connecting a keyboard and a mouse to the Raspberry, but I want to use Moonlight precisely because I want to play from the sofa... XD
    If there is something I can do or read to approach this without bothering you anymore, I would thank you a lot!

    PD: Just in order to add a question that doesn't have much to do with Moonlight itself... Have you found a way to avoid Geforce Experience upgrading to 3.13?

    Thank you for your patience!! 😉

  • @cheemix eventually download https://github.com/irtimmer/moonlight-embedded/blob/master/gamecontrollerdb.txt, replace the one in configs/moonlight, and add moonlight.configfile=dummy in recalbox.conf, it might solve the problem eventually

  • Thank you very much!!

Log in to reply

Want to support us ?