Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problem with moonlight

  • @jor2404 said in Problem with moonlight:

    @jovanny-paulin said in Problem with moonlight:

    What worked for me:
    1.- Unistall the actual GFE
    2.-download version GFE link
    3.- Go to C:\Windows\System32\drivers\etc and edit (with admin privileges) the file hosts
    just add at the end the line " services.gfe.nvidia.com #Block GFE Updates" whitout quotes this should block all updates redirecting the program to a non-exist server
    4.- install the GFE
    5.- once installed its time to do all the pair thing on recalbox

    You are right I didn´t read your answer until now but I was making tests yesterday and I realize that the solutio is to block
    ota-downloads.nvidia.com as you say. Finally we have a solution 🙂
    @Substring maybe it could be a good idea to make a reference for this solution in recalbox documentation to warranty that everybody can still enjoy moonlight in spite of the new Geforce Experience version.

    If yo have problems pairing after this go to GFE end delete all shield devices, the run ./Moonlight.sh clean and after this pair again

    Now my problem is that games are not launched from moonlight, before this process with GFE I run the games perfectly. Now I only see again a black screen. Anyone knows how to solve this?

  • @Substring I have tried with GFE versions that previosuly works ok but now I still can´t launch games from moonlight.

    Pairing process seems to work correctly but in es_launch_stderr.log I get:
    You must pair with the PC first

    And in es_launch_stdout.log:

    /usr/bin/moonlight stream -config /recalbox/share/system/configs/moonlight/moonlight.conf -mapping /recalbox/share/system/configs/moonlight/mappingP2.conf -input /dev/input/event2 -mapping /recalbox/share/system/configs/moonlight/mappingP1.conf -input /dev/input/event3 -app FIFA 18
    Moonlight Embedded 2.2.2 (SDL;EMBEDDED;CEC;PI)
    Searching for server...
    Connect to
    NVIDIA GeForce GTX 750, GFE (protocol version 7)

    Any clue to solve my problem? Could have I deleted some necessary files into \recalbox\share\system\configs\moonlight?

  • @jor2404 run the Moonlight script with the clean parameter first

  • @substring I have run ./Moonlight.sh clean before run ./Moonlight.sh pair. Then it pairs correctly but I can´t launch the games and in es_launch_stderr.log I still get:
    You must pair with the PC first

  • @jor2404 have you edited the moonlight.conf to set a IP ?

  • @substring In moonlight.conf I edited this line at the top of the file:

    address =

    That ip is from my stream pc

  • @jor2404 am i rught to believe you don't have only one GFE PC ?

  • @jor2404 Today I was also trying to solve the blackscreen problem. I did all steps described in this forum but without success. I use it for running Steam and after selecting Moonlight the Steam was executed on my PC automatically but at my Raspberry there was only black screen again.
    Then I started following. I downloaded and installed latest fresh Recalbox image and did the Moonlight pairing with my computer. Everything was working at first try and games were running. But I do not wanted to configure whole Recalbox and Kodi again for the new SD card. So I made a backup of all files in /share/system/configs/recalbox/moonlight. Then I put back my old SD card deleted all files in share/system/configs/recalbox/moonlight and copied files from working card backup. After this step my old SD card started working and Moonlight is running games correctly.
    One hint: When I tried to delete the files from card if was not possible using the shared folder. It was necessary to stop the emulation station and login as root directly at RPi computer.

  • i always stuck on the pair thing...

    the last message i got is

    "Searching for server..."

    and then nothing happens and i do all the things in this thread above .. so i think dont know what to do

  • @gimpi it means it can't find a GFE host in your network

  • @substring yeah but What Can i do GFE is running and the stream Option is enabled

    I tried to put the IP into the moonlight config and Not i have only one PC running with gfe

    I tried with ethernet and WiFi always stuck on this point did i miss something?

  • @gimpi are your pi and GFE PC on the same subnetwork ? have you tried moonlight on your phone and see if it works ? Have you ever successfully streamed your games ? Is your GPU compatible with streaming ?

  • @substring hmmm how i Can See if There is in the same sub Network i Think so because i have only one Network here

    Dont try it with my Phone i will try this later

    Yes my gpu is Ready to stream gtx970

    I Just streamed via steam from my PC to my Windows Tablet

  • @gimpi can you reach recalbox through network shares ? can you ping your PC from Recalbox ?

  • @substring if i put the IP from recalbox into my Chrome Browser have access to All the Things i need

    I dont See the Box in the Windows Explorer / Network view where i Can See the Fritz Box

    The Ping Thing is Just Ping IP into the Controll Pannel (f4)? I will try

  • @gimpi just SSH to it otherwise

  • @substring ok if i try to stream via Smartphone and i add the IP from my PC they said unable to connect make Sure the Requiem Ports Are allowed through Firewall

  • @gimpi so that's a GFE configuration problem. Have you logged in an account in GFE ?

  • @substring yes im logged in an gfe Account

  • @gimpi said in Problem with moonlight:

    @substring yes im logged in an gfe Account

    OK i Think im on the good way if i deaktivate the Windows Firewall i have stream access with my Smartphone Cant try it with the Pi now so i have to allow GFE to communicate through the firewall

Log in to reply

Want to support us ?