Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

NESPI :Fan Control 2 problèmes résolus en même temps


  • Staff
    Moderator
    Team

    @evotk pas si tu mets "python" avant comme tu l'as fait.



  • @dragu said in NESPI :Fan Control 2 problèmes résolus en même temps:

    @EVOTk

    Tu est sur que au niveau du S99custom tu as

    #!/bin/bash
    
    test -e "/recalbox/share/system/custom.sh" && /recalbox/share/system/custom.sh $1
    

    et que ton script "ventil.py" existe bien dans le bon folder.

    Oui oui !


  • Banned

    @evotk said in NESPI :Fan Control 2 problèmes résolus en même temps:

    s99custom

    Et S99custom a toujours un grand S au début ?



  • @dragu Oui Oui, le nom n'est pas changer


  • Banned

    @EVOTk
    Tu sais bien qu'il faut un certain temps avant que le ventilateur démarre si tu reboot, puisque la température doit être au max.
    Tu as la ligne de contrôle avec print qui te montre au niveau du ssh l'exécution du script si tu enlève pour les test le # . Je pense que quelque part tu as une erreur méchante et bête.



  • @dragu

    Oui j'ai decommenté la ligne, et jai reglé la température sur 40 pour le voir démarrer tout de suite mais cela ne marche pas.
    Je ne voit meme pas les ligne des température s'afficher dans putty si je ne demarre pas moi meme le script avec :

    bash -x /recalbox/share/system/custom.sh
    

    Oui, une erreur bete c'est sur ! Mais je ne trouve pas je tourne en rond pourtant avec la commande si dessus, sa se lance, j'ai revérifier 30 fois S99custom mais il est identique a se que t ma donner ( dans le doute je les remodifier avec se que tu ma donner meme, mais c'est toujours pareil )


    Edit :

    J'ai modifier mon custom.sh comme ceci :

    #!/bin/bash
    recallog "Start Script Ventil"
    python /recalbox/share/scripts/ventil.py &
    

    et nul par dans les log je retrouve "Start Script Ventil"


  • Banned

    @EVOTk
    Tu utilise un éditeur linux ou notepad pour éditer les scripts ? Les line breaks peuvent incorporer des erreurs.



  • @dragu said in NESPI :Fan Control 2 problèmes résolus en même temps:

    @EVOTk
    Tu utilise un éditeur linux ou notepad pour éditer les scripts ? Les line breaks peuvent incorporer des erreurs.

    Heu, j'ai fait avec putty mais aussi NotePad++ ! Je vais recommencer en utilisant uniquement putty peut etre alors !

    Edit :

    Si jessaye :

     bash -x /etc/init.d/S99custom
    

    J'ai la réponse ;

    + test -e /recalbox/share/system/custom.sh
    + /recalbox/share/system/custom.sh
    /etc/init.d/S99custom: /recalbox/share/system/custom.sh: /bin/bash^M: bad interpreter: No such file or directory
    

    On dirait bien que mon custom est bugger, pourquoi "/bin/bash^M" ? Je suis aller le nettoyer, maintenant que je fait

     bash -x /etc/init.d/S99custom
    

    Sa se lance, mais au redemarrage sa marche pas :(


    J'ai rajouter dans S99custom :

    recallog "Start Script Ventil"
    

    et clairement on ne le retrouve jamasi dans les logs, que si je fait :

     bash -x /etc/init.d/S99custom
    

    pour le lancer moi meme, je deviens fou !! :)


    Encore Edit :

    J'ai refait un installation neuve sur une autre sd, et la en 5min sa marche ... je comprend pas


  • Banned

    @evotk said in NESPI :Fan Control 2 problèmes résolus en même temps:

    /bin/bash^M

    "^M" est le résultat de Notepad.



  • @dragu
    Oui je pense, mais meme apres avoir corriger tout sa c'est comme si S99custom n'était jamais appeler au démarrage. J'ai du faire quelques chose mais quoi ?

    En tout cas maintenant sa fonctionne, j'ai tout réinstaller je suis partie sur une base propre. Apres 3h d’acharnement, j'en avait marre :)

    Merci beaucoup a ceux qui m'ont aidé.



  • Bonjour à tous.

    Ce script pour lancer mon ventilateur (5V qui fonctionne très bien en 3.3V également) en fonction de la T° de mon RPi3 m'intéresse beaucoup.

    J'ai donc :

    • Acheté et reçu un ventilateur qui, si je le branche directement sur les pins 3.3V ou 5V tourne sans aucun problème
    • Créé un fichier run-fan.py de @Dragu (avec Notepad++) que j'ai placé dans le répertoire /recalbox/share/myscripts/
    • Modifié (toujours avec Notepad++) le fichier S99custom comme indiqué par @Dragu
    • Branché mon ventilo sur les pins 39 et 40 (car côte à côte) et édité le fichier run-fan.py pour remplacer le GPIO 18 par le 21.

    Problème, mon ventilo se lance dès le lancement de Recalbox, tourne "lentement" et il semblerait qu'il ne s'arrête pas lorsque la température baisse alors qu'il devrait.

    Qui plus est, j'ai l'impression que quand je le branche en 3.3V, le ventilo tourne plus vite... (comme si le GPIO 21 ne délivrait pas une puissance suffisante...

    Est-ce normal ?

    Au pire, je laisse comme ça car le ventilo se lance et s'éteint avec Recalbox, mais quitte à faire les choses, autant les faire bien (et cela me permettrait de faire un peu d'overclocking)


  • Banned

    @Retlaw
    Bonsoir,
    moi j'ai l'impression que tu as branché directement le ventilateur sur le Gpio 21 ?
    Or, le Gpio 21 ou Gpio 18 ou xx est juste là pour commander la base du transistor qui lui seulement met les 5 Volt sur ventilo. Les 5 Volt+ et la masse existent sur la prise Nespi, comme ça en général tu as juste besoin du Pin raccordé à la base du transistor S8050. Je pense bien qu'il marche mieux directement sur les 3,3V que a travers un pin de sortie. Mais il y a risque et cela ne fonctionne pas, comme tu as vu.



  • Bonsoir @Dragu !

    @dragu said :

    moi j'ai l'impression que tu as branché directement le ventilateur sur le Gpio 21 ?

    C'est le cas. J'ai cru comprendre qu'il fallait faire ainsi.

    @dragu said :

    Mais il y a risque

    Quel est-il ?

    @dragu said :

    Les 5 Volt+ et la masse existent sur la prise Nesp

    OK !
    Donc si je comprends mieux, si je veux une utilisation optimale, il me faut un transistor S8050 (ou autre ?), je relie une branche du transistor au 5V du RPi, une autre au 5V du ventilo, et celle "pilotant" le transistor au connecteur 21 (par ex). Et là, ça fonctionnera.

    Me trompe-je ?



  • @evotk et mettre le chemincomplet vers python ? Il n'y a pas de PATH défini lors de l'init, tout ce qui se lance sous root n'est pas dans un shell interactif


  • Banned

    @Retlaw
    Pourquoi un S8050 ? Parce qu'il digère 500mA contrairement à ses copains de même taille qui sont souvent limités à 100mA. Et aussi parce qu'il faut un NPN et pas un PNP. Maintenant pour la connection et une possibilité sans souder il faut juste suivre le premier link vers l'auteur.

    alt text



  • @Dragu , merci pour tes explications !!

    Je vais de ce pas commander ce qu'il faut !



  • Merci à tous pour vos échanges et vos conseils.
    Depuis ce matin, mon boitier NesPi bénéficie d'un ventilateur qui régule intelligemment la température.

    Après avoir validé la régulation ON/OFF, j'ai basculé sur une régulation PI en reprenant une partie du code disponible sur la page suivante :
    http://www.sensorsiot.org/variable-speed-cooling-fan-for-raspberry-pi-using-pwm-video138/

    D'après les premiers essais, ça fonctionne bien.



  • Personnellement je me suis pas embêté, j'ai soudé le ventilo sur une prise USB. Comme ça, quand le Raspberry s'arrête, les ports USB ne sont plus alimentés, et donc le ventilateur ne tourne plus



Want to support us ?

174
Online

74764
Users

19207
Topics

142776
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.