Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

How to get SEGA CD Working? Bios? etc?



  • @voljega Fixed! The problem? I was trying to run with my Games & BIOS entirely on USB drive. Evidently there is a huge glitch with this method. Even though stuff like Genesis games will run fine off of it. However, it absolutely will NOT boot Sega CD bios no matter what. But when i remove my USB drive and load the SEGA CD game & Bios directly to the SD card? It works perfect. WTF.



  • @skullgrin I've been running them on usb stick for as long as I can remember so I don't think this the problem...

    That said I didn't check in 4.1



  • @voljega Well i've tried various combinations to still allow use of the USB drive. Like loading the Bios onto both the SD card and USB, but keeping my games on the USB drive. Doesn't work.



  • @skullgrin they off course need to be on the same, ie either both on sd when using sd or both on usb key when usb key



  • @voljega I've also tried loading up all the exact same files on both USB and SD card (Bios and games), and switching between them using the menu(Internal, Anyexternal, and drive name). Each time the system reboots to use the desired storage. Every time the internal/SD card booted up SEGA CD Bios and games perfectly fine. And everytime i tried using Anyexternal/USB Drive or the Drive name, it never worked. Actually now my Genesis roms don't want to load any more either. Both them and the SEGA CD games are recongized as present in the menu but, when i try to play them, it just leads to a blank screen. Sometimes freezes the system up.

    That's pretty cut & dry. USB drive won't work. I am using Latest Recalbox also.



  • @skullgrin hmmm maybe your usb drive is fuckep up then, did you try to connect it on windows and repair it ?



  • @voljega It's a brand new, Sandisk 16GB USB drive. Every time i disconnected it from the RPI3 and connected it to my PC, it works great. UNLESS i'm supposed to actually load the entire Recalbox O.S onto it as well, not just roms? Right now i have the O.S loaded to the SD card, and was trying to load the actual roms from USB drive.



  • @skullgrin yeah you're doing it right. are you powering off your pi properly throught the EmulationStation menu and not just disconnecting the power cable or socket ?



  • @voljega Yes. I use the menu to restart the system. Although i've also just unplugged it to shut it off. In many cases i had no choice, because trying to boot up SEGA CD caused it to freeze on a blank screen. Maybe if i just loaded up the entire O.S, as well as games to the USB drive and nothing on SD card? Can that be done?



  • @skullgrin no it can't be done.

    When the system freeze, try to connect to it through putty and type the command reboot to restart it

    OK you may have fried your usb card partition then. If you're still in a testing process, you can try to reformat it (prefer FAT32), switch the external partition to none, reconnect the key, then reswitch external partition to any external, it will recreate the partition from scratch.

    Then try recoping your bioses and games in the right places on the usb key, reboot and retry



  • @voljega Holy crap! So i tried everything again, using the same official tutorial as before to get USB drive working but, this time used an older 128GB USB drive i had. Loaded up the Bios and roms as before and....it works!! WTF. The other drive i was using was a brand new, from the package, 16GB USB. Followed the same directions and got nothing. But its working now with my 128GB. SEGA CD Bios and games boot up fine. I don't get it. I did everything the same as before. Oh well, at least its working now.


Log in to reply
 

Want to support us ?

Join us on :

249
Online

49303
Users

17609
Topics

132765
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.